# Table of Contents

Table of Contents .............................................................................................................. i  
List of Figures ........................................................................................................................ vii  

1. Introduction ................................................................................................................... 1-1  
   1.1. About Automation Studio ..................................................................................... 1-1  
   1.1.1. General Information ................................................................................. 1-1  
   1.1.2. Sequence of Tasks .................................................................................... 1-2  
   1.2. Contents of the Document .................................................................................... 1-3  
   1.3. Conventions Used in this Document ................................................................. 1-3  
   1.3.1. Typographical Conventions ................................................................. 1-3  
   1.3.2. Choosing Versus Selecting ....................................................................... 1-4  
   1.3.3. Combinations and Sequences of Keys ..................................................... 1-4  
   1.3.4. Basic Notions and Terminological Conventions ........................................ 1-4  
   1.3.5. Terms Connected with the Use of the Mouse ............................................ 1-4  
   1.3.6. Notice and Tip .......................................................................................... 1-5  

2. Getting Started .............................................................................................................. 2-1  
   2.1. Starting Automation Studio ................................................................................. 2-1  

3. Diagram Editor .............................................................................................................. 3-1  
   3.1. Static Elements ................................................................................................. 3-2  
   3.1.1. Title Bar of the Software ......................................................................... 3-2  
   3.1.2. Menu Bar ................................................................................................. 3-2  
   3.1.3. Toolbars .................................................................................................. 3-22  
   3.1.4. Status Bar ............................................................................................... 3-27  
   3.1.5. Plotter ..................................................................................................... 3-27  
   3.1.6. Message Window ................................................................................... 3-29  
   3.2. Management Utilities ........................................................................................ 3-30  
   3.2.1. Library Explorer ..................................................................................... 3-30  
   3.2.2. Project Explorer ..................................................................................... 3-32  
   3.2.3. Variable Manager ................................................................................... 3-33
3.3. Pop-up/Contextual Menus ................................................................. 3-39
  3.3.1. Open a pop-up Menu ................................................................. 3-39
  3.3.2. Pop-up Menus’ Specific Commands ............................................. 3-39

4. Creation and Management of a Project and its Documents .............. 4-1
  4.1. Creation of a New Project ............................................................... 4-1
    4.1.1. Saving a New Project ............................................................... 4-2
    4.1.2. Opening a Project ................................................................. 4-3
    4.1.3. Closing a Project ................................................................. 4-4
  4.2. Creating a New Document ............................................................. 4-4
    4.2.1. Creating a New Diagram ......................................................... 4-4
    4.2.2. Creating a Sequential Functional Chart (Non Standard Workshop) .... 4-5
    4.2.3. Creating a New Report ............................................................ 4-6
    4.2.4. Inserting a Web Page .............................................................. 4-6
    4.2.5. Inserting a New External Document ........................................ 4-7
    4.2.6. New Folder ............................................................................. 4-8
  4.3. Saving a Template ................................................................. 4-8
    4.3.1. Project Template ................................................................. 4-8
    4.3.2. Diagram Template ............................................................... 4-9
    4.3.3. Report Template ................................................................. 4-9
  4.4. Saving a Project ................................................................. 4-10
    4.4.1. Project Save As ................................................................. 4-10
  4.5. Project Properties ............................................................... 4-10
    4.5.1. General Branch ................................................................. 4-11
    4.5.2. Summary Info Branch ......................................................... 4-11
    4.5.3. History Branch ................................................................. 4-13
  4.6. Print ................................................................. 4-15
    4.6.1. Print Preview ................................................................. 4-15
  4.7. Exporting a Diagram ............................................................... 4-17
  4.8. Sending a Project To ............................................................... 4-17
  4.9. Exiting from the Application ........................................................ 4-18

5. Creating a Diagram ............................................................................ 5-1
  5.1. Document Properties ............................................................... 5-1
5.1. Page Setup Branch .............................................................. 5-1  
5.1.2. Summary Info Branch .................................................. 5-4  
5.1.3. Diagram Branch ............................................................ 5-6  
5.1.4. History Branch ............................................................ 5-7  
5.2. Layout of Elements Within a Diagram ............................... 5-8  
5.2.1. Layout of Components and Use of Library ................... 5-8  
5.2.2. Layout of Links ........................................................... 5-9  
5.2.3. Verifying Connections ................................................ 5-15  
5.3. Component Properties .................................................... 5-16  
5.3.1. Introduction ................................................................. 5-16  
5.3.2. Standards and Specifications ...................................... 5-16  
5.3.3. Component Properties Dialog Box ............................... 5-17  
5.3.4. Components’ Technical Data ....................................... 5-18  
5.3.5. Catalog Information ................................................... 5-19  
5.3.6. Displayed Information ................................................ 5-20  
5.3.7. Characteristic Curves ................................................. 5-22  
5.3.8. Component Configurator ............................................. 5-24  
5.3.9. Variable Assignment .................................................. 5-24  
5.4. Detailed Information on the Component ........................... 5-38  
5.5. Modifying a Diagram ..................................................... 5-38  
5.5.1. Element Selection ....................................................... 5-38  
5.5.2. Relocating Elements ................................................... 5-40  
5.5.3. Duplicating Elements ................................................ 5-40  
5.5.4. Deleting Elements ..................................................... 5-41  
5.5.5. Modifying Elements ................................................... 5-41  
5.5.6. Transferring Elements Between Diagrams .................. 5-42  
5.5.7. Properties of a Component or Selection ....................... 5-43  
5.5.8. Connection Ports and Contact Points ......................... 5-43  
5.5.9. Connection Ports Name ............................................. 5-44  
5.5.10. Component Snap ...................................................... 5-45  
5.5.11. Grid Properties ........................................................ 5-45  
5.6. Inserting a Graphic Element ........................................... 5-46  
5.6.1. Inserting a Line, a Rectangle, and an Ellipse ................. 5-46
5.6.2. Inserting a Text Box, a Picture, and a Field............................................ 5-47
5.6.3. Inserting a Link, an Arc, and a Polygon ................................................. 5-48
5.6.4. Attributes of Graphic Objects.................................................................... 5-49
5.6.5. Plotter....................................................................................................... 5-51
5.6.6. Bill of Materials (BOM)........................................................................... 5-52
5.7. Simulation...................................................................................................... 5-52
  5.7.1. Description of the Simulation Mode....................................................... 5-53
  5.7.2. Simulation Speeds.................................................................................. 5-55
5.8. Verify Connections....................................................................................... 5-57
  5.8.1. Detecting Errors in Simulation............................................................... 5-58

6. Plotter ................................................................................................................ 6-1
  6.1. Accessing the Plotter................................................................................... 6-1
  6.2. Using the Plotter......................................................................................... 6-2
  6.3. Plotting the Curve....................................................................................... 6-3
    6.3.1. Preserving Visual Data........................................................................ 6-3
    6.3.2. Preserving Textual Data....................................................................... 6-3
    6.3.3. Modifying the Colour of the Plot........................................................ 6-3
    6.3.4. Modifying the Plot Scale of a Variable............................................... 6-4
    6.3.5. Deleting a Curve.................................................................................. 6-5
  6.4. Variables That Can Be Plotted..................................................................... 6-5

7. Field Configuration ............................................................................................ 7-1
  7.1. Configuring Properties Fields..................................................................... 7-1
    7.1.1. Adding User-Defined Fields............................................................... 7-2
    7.1.2. Modifying a User-Defined Field........................................................ 7-3
    7.1.3. Deleting a User-Defined Field............................................................ 7-4
    7.1.4. Associating User-Defined Fields to a Component............................. 7-5
  7.2. Inserting Fields......................................................................................... 7-6

8. Catalog .............................................................................................................. 8-1
  8.1. Accessing the Catalog................................................................................ 8-1
    8.1.1. Adding Accessories............................................................................ 8-2
  8.2. Saving the Information................................................................................ 8-3
11.1.5. SFC Module ...........................................................................................11-5
11.1.6. Simulation Module .................................................................................11-6
11.1.7. Plotter Module ......................................................................................11-6
11.1.8. Hydraulic Workshop ............................................................................11-7

A. Shortcuts .............................................................................................................. A-1
B. Glossary ............................................................................................................... B-1
C. Index ..................................................................................................................... C-1
List of Figures

Figure 1–1: Tasks sequence....................................................................................................1-2
Figure 2–1: Automation Studio’s main window.................................................................2-2
Figure 3–1: Diagram Editor...............................................................................................3-1
Figure 3–2: Title bar of the Automation Studio on opening.............................................3-2
Figure 3–3: Menu bar .......................................................................................................3-2
Figure 3–4: File menu......................................................................................................3-3
Figure 3–5: New submenu...............................................................................................3-4
Figure 3–6: Save as Template submenu.........................................................................3-4
Figure 3–7: Edit menu.....................................................................................................3-6
Figure 3–8: View menu ..................................................................................................3-8
Figure 3–9: Insert menu..................................................................................................3-10
Figure 3–10: Layout menu............................................................................................3-12
Figure 3–11: Simulation menu ......................................................................................3-14
Figure 3–12: Tools menu...............................................................................................3-16
Figure 3–13: Simulation and Multiwindowing...............................................................3-18
Figure 3–14: Window menu..........................................................................................3-19
Figure 3–15: Display submenu.....................................................................................3-19
Figure 3–16: Help menu...............................................................................................3-20
Figure 3–17: Online Support submenu.........................................................................3-21
Figure 3–18: Project toolbar.........................................................................................3-22
Figure 3–19: Edit toolbar...............................................................................................3-23
Figure 3–20: Simulation toolbar...................................................................................3-24
Figure 3–21: View toolbar............................................................................................3-24
Figure 3–22: Insert toolbar..........................................................................................3-25
Figure 3–23: Layout toolbar..........................................................................................3-26
Figure 3–24: Format toolbar .................................................................................................3-27
Figure 3–25: Status bar .........................................................................................................3-27
Figure 3–26: Plotter ..............................................................................................................3-28
Figure 3–27: Library Explorer window ................................................................................3-31
Figure 3–28: Library Explorer toolbar ..............................................................................3-32
Figure 3–29: Project Explorer window .................................................................................3-33
Figure 3–30: Variable Manager window ............................................................................3-33
Figure 3–31: Add a Variable dialog box .............................................................................3-35
Figure 3–32: Modify Variable dialog box ...........................................................................3-37
Figure 4–1: Project Templates dialog box ........................................................................... 4-1
Figure 4–2: Save as dialog box .......................................................................................... 4-2
Figure 4–3: Open dialog box .............................................................................................. 4-3
Figure 4–4: Diagram Templates dialog box ........................................................................ 4-5
Figure 4–5: Project Properties dialog box, Summary Info branch ..................................... 4-11
Figure 4–6: Project Properties dialog box, History branch ................................................... 4-13
Figure 4–7: Items for Print Preview and Print dialog box .................................................... 4-16
Figure 4–8: Print Preview window ...................................................................................... 4-17
Figure 4–9: Confirmation dialog box .................................................................................. 4-18
Figure 5–1: Map locator inserted in the diagram ............................................................... 5-2
Figure 5–2: Document Properties dialog box, Page Setup branch ................................... 5-3
Figure 5–3: Document Properties dialog box, Summary Info branch ................................ 5-5
Figure 5–4: Document Properties dialog box, Diagram branch ........................................ 5-6
Figure 5–5: Document Properties dialog box, History branch .......................................... 5-7
Figure 5–7: Example of a divide link .................................................................................. 5-11
Figure 5–8: Modifying the shape of a link .......................................................................... 5-13
Figure 5–9: Example of a Component Properties dialog box allowing the modification of a link’s properties ................................................................. 5-14
Figure 5–10: Messages window – Example of messages following a connection verification ........................................................................................................ 5-15
List of Figures

Figure 5–11: Component Properties dialog box of a single component or group ..........5-17
Figure 5–12: Component Properties dialog box, Catalog Information branch ..........5-20
Figure 5–13: Component Properties dialog box, Displayed Information branch ..........5-21
Figure 5–14: Component Properties dialog box, Characteristic Curves ......................5-22
Figure 5–15: Component Properties dialog box, Variable Assignment branch for transmitter and receiver components ..............................................................5-25
Figure 5–16: OPC Settings dialog box, Link tab ..........................................................5-30
Figure 5–17: OPC Settings dialog box, Server tab .........................................................5-31
Figure 5–18: Add Server dialog box ..............................................................................5-32
Figure 5–19: OPC Settings dialog box, Group tab .........................................................5-33
Figure 5–20: Add Group dialog box ..............................................................................5-34
Figure 5–21: OPC Settings dialog box, Link tab – Links created .....................................5-36
Figure 5–22: Component Properties dialog box after the creation of OPC links ............5-38
Figure 5–23: Receiver component after the creation of a Read external link ....................5-38
Figure 5–24: Creation of a frame for a multiple elements selection ..................................5-39
Figure 5–25: Two types of connectors: connections (circles) and mechanical contacts (diamonds) ..........................................................5-44
Figure 5–26: Component with a connection number ......................................................5-44
Figure 5–27: Grid Properties dialog box .......................................................................5-46
Figure 5–28: Component Properties dialog box, graphic object ..................................5-50
Figure 5–29: Plotter window .........................................................................................5-51
Figure 5–30: Verify Connections dialog box .................................................................5-58
Figure 6–1: Plotter in the interface .................................................................................6-1
Figure 6–2: Plots Selection dialog box ...........................................................................6-2
Figure 6–3: Colours dialog box .....................................................................................6-4
Figure 7–1: Field Configuration dialog box .....................................................................7-1
Figure 7–2: Add field dialog box ....................................................................................7-2
Figure 7–3: Modify Field dialog box ................................................................................7-3
Figure 7–4: Field Delete Warning Message Box .............................................................7-4
Figure 7–5: Field Selection dialog box ................................................................. 7-5
Figure 8–1: Catalog Browser dialog box ............................................................... 8-2
Figure 9–1: Report Templates dialog box .............................................................. 9-1
Figure 9–2: Report Configuration dialog box, Filter Configuration tab ............... 9-2
Figure 9–3: Report Configuration dialog box, Field Selection tab ....................... 9-2
Figure 9–4: Report Configuration dialog box, Global Settings tab ....................... 9-3
Figure 9–5: Example of a report ........................................................................... 9-4
Figure 9–6: Sort dialog box .................................................................................. 9-8
Figure 9–7: Group dialog box .............................................................................. 9-8
Figure 10–1: Interaction between the software and a PLC ..................................... 10-1
Figure 10–2: Interface workshop library............................................................... 10-3
Figure 10–3: Example of the I/O interface card symbol ........................................ 10-4
Figure 10–4: Example of an electropneumatic circuit ........................................... 10-5
Figure 10–5: Sequence SFC ................................................................................ 10-7
Figure 10–6: Ladder logic diagram of the sequence .............................................. 10-8
Figure 11–1: Options dialog box ........................................................................ 11-1
1. Introduction

Automation Studio is a design, animation and simulation software tool. It was created for the automation industry, specifically to fulfill training and testing requirements. The workshops associated with the software reflect the prevailing usage in the industry as closely as is possible. The simulation utility makes Automation Studio an efficient tool for the certification of automated processes and programs.

In the Automation Studio environment, all the design tools are readily accessible. The core system contains three utilities: a Diagram Editor, a Project Explorer, and a Library Explorer. The Diagram Editor allows you to generate and simulate diagrams and create reports, while the Project Explorer handles file management and the classification of all documents associated with a simulation project. The Library Explorer supplies the symbols libraries necessary for the creation of the diagrams that make up your projects.

Finally, this software allows you to document your project. You can print and export your diagrams along with the various associated lists and reports to assemble a complete work file.

1.1. About Automation Studio

Automation Studio is a simulation software package into which various modules may be plugged.

Each module, also called a workshop, includes a component library with which you can create different types of circuits such as hydraulic, pneumatic, electric, etc. These can be created by themselves or combined with other circuit types.

Automation Studio handles the editing, simulation, file and diagram management, printing and display functions.

1.1.1. General Information

The Automation Studio user documentation has a modular structure. The current Automation Studio - User’s Guide contains information on the main functions of the Project Explorer, the Library Explorer, the Diagram Editor for the standard workshops (Hydraulic, Pneumatic, Electrical Controls, Numerical, Scale Diagrams) and the Simulation mode. For each non-standard workshop you will find a User’s Guide providing specific information including a Quick Start Guide to quickly help you familiarize yourself with the different functions related to that workshop.
1.1.2. Sequence of Tasks

The sequence of tasks described in this section reflects the sequence that is normally followed when using the core system. In reality, changes and improvements made during the course of a project often require that some steps be repeated or restarted. Furthermore, this guide deals only with the general aspects of Automation Studio; functions specific to the workshops are therefore not described in this document.

**Figure 1–1: Tasks sequence**
1.2. Contents of the Document

The workshops User's Guides complement this core system User's Guide. The workshop documents explain the theory and use of the software with exercises and examples so that the workshop technology is easily understood.

Refer to the workshops User's Guide for information on the different functions, components and examples of applications required to learn and use Automation Studio.

All the instructions required to use the functions that are shared by all the workshops can be found in this User's Guide. Specifically, these include the Project Explorer, the Library Explorer, and the Diagram Editor environments, along with their commands and dialog boxes. Instructions that are essential to the simulation of the different workshop’s technologies are also described.

Instructions are presented in the order in which the work should be executed. The content is organized so that each step in each section follows the next step very closely. In fact, the basic Automation Studio system can be learned by reading this guide and following the sequence of chapters as they are presented. For tasks specific to a workshop, you must read the User’s Guide supplied with that specific workshop.

You may also obtain needed information by consulting the index and the appendices at the end of this document for a summary of reference data.

1.3. Conventions Used in this Document

It is important to know the conventions used in this guide. They were designed to present the information in this document in a clear and structured way. These same conventions have been used in the user's guides of all of the different workshops.

1.3.1. Typographical Conventions

The following specific typographical formats are employed in this guide.

The names of the user interface elements such as the menus, commands, dialog boxes, buttons and fields are typed with a capital at the beginning of the word.

- Example: Choose File → Open.

The names of the keyboard keys are shown in small capitals.

- Example: Press on the SHIFT key to separate a component from a link.

The names of files and directories appear in capital letters.

- Example: In the Directories list, select the C:\PROJECTS directory.

Text, which must be entered as shown, appears in bold.
• Example: Type `setup.exe` and then press the ENTER key to start the installation software.

Names of variables, diagram titles and text representing information you must provide are indicated in italics.

• Example: In the File Name box, type the name of your file with the .PR4 extension, in the form `name.PR4`.

• Example: For more information, refer to the Windows User's Guide.

### 1.3.2. Choosing Versus Selecting

The word "choose" indicates a selection that triggers an action.

• Example: Choose the File → Exit.

The word select is used when identifying an object to be modified or when selecting an option in a dialog box.

• Example: Select the printer driver from the Printer drop-down list box.

### 1.3.3. Combinations and Sequences of Keys

+KEY1+KEY2: The plus sign (+) indicates that you press and hold down the first key while pressing the second key.

• Example: `CTRL+A`  

,KEY1, KEY2: The comma (,) directs you to press on the two keys successively.

• Example: `ALT, F`

### 1.3.4. Basic Notions and Terminological Conventions

There are two terminological conventions used in this document. One is for terms connected with the use of the mouse, and the second is for icons used in this document.

### 1.3.5. Terms Connected with the Use of the Mouse

<table>
<thead>
<tr>
<th>Term</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>Point to an element</td>
<td>Position the mouse pointer on an element of the screen.</td>
</tr>
<tr>
<td>Click</td>
<td>Press and immediately release the mouse button. Unless otherwise indicated, click with the left mouse button.</td>
</tr>
</tbody>
</table>
Double-click  Press the mouse button twice in quick succession. Unless otherwise indicated, double-click with the left mouse button.

Drag  Press and hold the left mouse button as you move the mouse pointer across the screen.

### 1.3.6. Notice and Tip

The current help document uses icons to represent important notes and tips that simplify the commands that can be used.

<table>
<thead>
<tr>
<th>Icon</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>![Icon]</td>
<td>Indicates an important notice or a notion to pay attention to.</td>
</tr>
<tr>
<td>![Icon]</td>
<td>Indicates a tip that will simplify the use of commands in Automation Studio.</td>
</tr>
<tr>
<td>![Icon]</td>
<td>Indicates that a pop-up menu is available for that specific procedure.</td>
</tr>
</tbody>
</table>
2. Getting Started

This chapter describes the application’s basic procedures and user interface.

2.1. Starting Automation Studio

There are different techniques of starting Automation Studio. You may choose the starting option which best suits your needs.

After Automation Studio has been installed, an icon is displayed on Windows’ desktop.

To start Automation Studio:
1. Click on the Start menu at the bottom of the screen.
2. Select the Program item.
3. Select the Automation Studio 4 item.
4. Select the Automation Studio 4 command.

Double-click on the Automation Studio icon on your desktop.

The main window of Automation Studio opens as shown in the following figure.
Upon opening, the Automation Studio window exposes a blank diagram. It also introduces the Diagram Editor, the Project Explorer, and the Library Explorer and their associated toolbars.

The following chapter contains the detailed description of Automation Studio’s main window. In order to avoid redundancy in the information contained in the guide, functions appearing in the menus, toolbars and pop-up menus will only be described in the menus and will be referenced to throughout the user’s guide.
3. Diagram Editor

This section introduces a detailed description of each item making up the main window of Automation Studio. Items in the main window are divided in two categories: static and dynamic.

![Diagram Editor](image)

Figure 3–1: Diagram Editor

A Title bar (static);
B Menu bar (static);
C Various toolbars (static);
D Library Explorer (dynamic);
E Project Explorer (dynamic);
3.1. Static Elements

The static elements cover the title bar, menu bar, and the various toolbars. You may choose to display and move the toolbars depending on your needs.

3.1.1. Title Bar of the Software

On starting Automation Studio, the title bar of the Diagram Editor displays by default « Automation Studio – [ASProjet1 : Diagram1] ». When saving for the first time or when opening an existing project, the title bar displays the name of the software followed by the name of the project and current diagram.

![Figure 3–2: Title bar of the Automation Studio on opening](image)

3.1.2. Menu Bar

The menu bar of the Diagram Editor contains nine menus. Each of these menus as well as their content is described in the following pages.

![Figure 3–3: Menu bar](image)

3.1.2.1. File Menu

The File menu comprises all the menu commands related to the management of project files (creating, opening, saving, and printing) and to the opening of version 3 and higher project files.
New Project…

This command allows the user to create a new project based on the available templates.

Open Project…

This command allows the user to open an existing project including those created in version 3.x.

Close Project

This command allows the user to close a project and save, or discard, modifications made. See section Saving a Project for the procedure.

New

This command allows the user to create a new document based on the following list:
• Diagram: Create a new diagram.
• Sequential Function Chart: Allows inserting and creating a new SFC (non standard module) if authorized by the license.
• Report: Allows inserting a Bill of Material (BOM) or Report document type.
• Web Page: Allows inserting a link to a Web page.
• Other Document…: Allows inserting a document other than an Automation Studio document. This document must come from an application properly installed on the user’s workstation.
• Directory: Allows adding directories and subdirectories.

**Save as Template…**

This command allows saving a document as a template based on the following list:

- Project…: Allows the user to save a project template.
- Diagram…: Allows the user to save a diagram template.
- Sequential Function Chart …: Allows the user to save an SFC template.
- Report…: Allows the user to save a report template.

**Save Project**

This command allows the user to save a project as well as the modifications made. See section Saving a Project for the procedure.
Save Project as…
This command allows the user to save, a project and its modifications under a different name without affecting the original version of the document. See section Saving a Project for the procedure.

Project Properties…
This command allows the user to enter, verify, and modify information concerning the current project. See section Project Properties to find out more about the tabs in the Project Properties dialog box.

Print Preview
This command allows the user to preview the current project before printing its contents. See section Print Preview for the procedure.

Print…
This command allows the user to print part or all of the current project’s diagrams. See section Print for the procedure.

Send to…
This command allows a compressed copy of the current project to be sent via email. See section Sending a Project To for the procedure.

Exit
This command allows the user to completely close the application as opposed to the Close command that only allows the user to close the current project. See section Exiting from the Application for the procedure.

3.1.2.2. Edit Menu
The Edit menu comprises all the menu commands related to the viewing and modification of document properties, selected items on a diagram, and the editing commands related to a selection on the Diagram Editor.
Undo
This command allows the user to cancel the last action performed in the current document.

Redo
This command allows the user to reinstate the action, previously undone, performed in the current document.

Cut
This command allows the user to remove a selected item from the current document and store it in the clipboard.

Copy
This command allows the user to copy a selected item from the current document and store it in the clipboard.

Paste
This command allows the user to insert an item from the clipboard into the current document.
Duplicate

This command allows the user to make an identical copy of a selected item from the current document.

Delete

This command allows the user to suppress a selected item from the current document, with the exception of components’ satellites.

Select All

This command allows the user to select every item present on the diagram.

Component Properties…

This command allows the user to view, enter, and modify information related to the selected item in the current project.

Document Properties…

This command allows the user to view, enter, and modify information related to the current document.

3.1.2.3. View Menu

The View menu comprises all the commands related to the modification of the viewing properties of a diagram.
Figure 3–8: View menu

**Previous Zoom**

This command allows the user to revert to the last view percentage.

**Window Zoom**

This command allows the user to select an area of the diagram and set the magnification in proportion to the selected area.

**Zoom +**

This command allows the user to view the page from a magnification percentage of 25% to a maximum of 800% independently of the selected area.

**Zoom –**

This command allows the user to view the page from a magnification percentage of 800% to a minimum of 25% independently of the selected area.
**Zoom All Components**

This command allows the user to view the complete set of components on the page independently of their position on the diagram.

**Page Zoom**

This command allows the user to view the entire page in its height.

**Panning**

This command allows the user to translate the page in real time and its content in a multidirectional movement.

**Grid**

This command allows the user to display the grid used to snap symbols into place.

**Rulers**

This command allows the user to display or not the vertical and horizontal rulers.

**Contact Points**

This command allows the user to view the contact points of each symbol on the diagram.

**Connection Ports**

This command allows the user to view the connection ports of each symbol on the diagram.

**Connection Ports Names**

This command allows the user to view the name of all the connection ports of each symbol on the diagram.

**Component Snap**

This command, when checked, ensures that the symbols from the libraries will snap to the grid on the diagram.
Grid Properties

This command allows the user to modify the drawing elements’ snap properties as well as the colour of the grid.

3.1.2.4. **Insert Menu**

The Insert menu comprises the commands related to adding drawing elements and text fields to a diagram. This menu is visible only when a diagram is active.

![Insert menu](image)

*Figure 3–9: Insert menu*

**Line**

This command allows the user to draw lines on a diagram.

**Rectangle**

This command allows the user to draw rectangles on a diagram.

**Arc**

This command allows the user to draw arcs on a diagram.

**Ellipse**

This command allows the user to draw ellipses of various sizes on a diagram.
**Polygon**

This command allows the user to draw polygons of various sizes on a diagram.

**Text**

This command allows the user to insert text areas in a diagram.

**Picture...**

This command allows the user to insert a JPG and BMP format image in a diagram.

**Field...**

This command allows the user to insert automatic fields containing the current diagram or project properties.

**Bill of Materials**

This command allows the user to insert in a diagram a bill of material containing the Quantity and Name of Component properties.

**Link**

This command allows the user to insert a link in a diagram.

### 3.1.2.5. Layout Menu

The Layout menu comprises all the commands related to the modification of the orientation and layout of elements in a diagram. This menu is visible only when a diagram is active.

In this case, an object can be a symbol, a group, or a multiple selection of these elements. If the selection is a group, the layout functions will be applied on the axis of symmetry and on the centre of rotation of the group. If it is a multiple selection, the layout functions will be applied individually on each element of the selection.
### Layout Menu

<table>
<thead>
<tr>
<th>Command</th>
<th>Hotkey</th>
</tr>
</thead>
<tbody>
<tr>
<td>180° Rotation</td>
<td></td>
</tr>
<tr>
<td>90° Left Rotation</td>
<td></td>
</tr>
<tr>
<td>90° Right Rotation</td>
<td></td>
</tr>
<tr>
<td>Vertical Flip</td>
<td></td>
</tr>
<tr>
<td>Horizontal Flip</td>
<td></td>
</tr>
<tr>
<td>Bring Forward</td>
<td>Ctrl+G</td>
</tr>
<tr>
<td>Bring to Front</td>
<td></td>
</tr>
<tr>
<td>Send to Back</td>
<td></td>
</tr>
<tr>
<td>Send Backward</td>
<td></td>
</tr>
<tr>
<td>Group</td>
<td>Ctrl+G</td>
</tr>
<tr>
<td>Ungroup</td>
<td>Ctrl+U</td>
</tr>
<tr>
<td>Direct Link</td>
<td>Ctrl+L</td>
</tr>
<tr>
<td>Break Link</td>
<td></td>
</tr>
<tr>
<td>Join Links</td>
<td></td>
</tr>
<tr>
<td>Convert Link to Jumps</td>
<td>Ctrl+J</td>
</tr>
</tbody>
</table>

![Figure 3–10: Layout menu](image)

**Rotate 180°**

This command allows the user to apply a rotation of 180 degrees to a selected object.

**Rotate Left**

This command allows the user to apply a counter clockwise rotation of 90 degrees to a selected object.

**Rotate Right**

This command allows the user to apply a clockwise rotation of 90 degrees to a selected object.

**Vertical Flip**

This command allows the user to transpose a selected object on its vertical axis.

**Horizontal Flip**

This command allows the user to transpose a selected object on its horizontal axis.
Inserted symbols are laid on overlapping layers. The first layer can be seen above all the others and the last layer is below all the others.

**Bring to Front**
This command allows the user to bring a selected object onto the first layer of the elements on the diagram.

**Send to Back**
This command allows the user to bring a selected object onto the last layer of the elements on the diagram.

**Bring Forward**
This command allows the user to bring a selected object one layer above the current one.

**Send Backward**
This command allows the user to bring a selected object one layer below the current one.

**Group**
This command allows the user to bring together selected objects into one element called a group.

**Ungroup**
This command allows the user to break up a selected element into individual objects.

A link is a line connecting two or more symbols to be simulated.

**Direct Link**
This command allows avoiding all detours within a link. In other words, this command applies the “shortest distance between two points” philosophy.
Break Link
This command allows the user to divide a link into two or more segments.

Join Links
This command allows the user to unite two distinct links into one.

Convert Link to Jumps
In the standard modules, this command allows the user to transform a link between two components into two jumps. These jumps have an identical mnemonic in order to reduce the number of links within a circuit.

Jumps may be inserted from the library in order to keep the circuits that are spread out on several diagrams linked together.

3.1.2.6. Simulation Menu
The Simulation menu comprises the commands related to the simulation of a project or a diagram.

The simulation of a project or diagram launches the simulation engine that computes and solves of the selected portion of the drawn circuit and responds with the behaviour and animation of symbols.

![Simulation Menu](image)

*Figure 3–11: Simulation menu*
Normal
This command allows the user to simulate a circuit in normal mode. This mode corresponds to the maximum speed of the simulation evaluation based on the installation.

Step by Step
This command allows the user to simulate a circuit in the Step by Step mode.

Slow Motion
This command allows the user to simulate a circuit in a slow motion mode.

Pause
This command allows the user to temporarily stop the simulation of a circuit and to resume it later on.

Stop
This command allows the user to permanently stop a simulation and to return to the editing mode.

Project
This command allows the user to simulate the set of diagrams included in the current project.

Document
This command allows the user to simulate the current diagram.

Selection
This command allows the user to simulate the previously selected diagrams with the Simulated Items command.

Select Items to Simulate
This command allows the user to select diagrams from the current project for their simultaneous simulation.
3.1.2.7. Tools Menu

The Tools menu comprises the commands related to the configuration of the software and fields, and the verification and export of a diagram.

---

<table>
<thead>
<tr>
<th>Tools</th>
</tr>
</thead>
<tbody>
<tr>
<td>Verify Connections…</td>
</tr>
<tr>
<td>Export…</td>
</tr>
<tr>
<td>Field Configuration…</td>
</tr>
<tr>
<td>Options…</td>
</tr>
</tbody>
</table>

Figure 3–12: Tools menu

**Verify Connections…**

This command allows the user to verify all the connections on every component in the active diagram.

**Options…**

This command allows the user to adjust the application and its modules based on his preferences.

**Field Configuration…**

This command allows the user to customize property fields.

**Export…**

This command allows the user to export the current diagram. See section Exporting a Diagram for the procedure.

**Update Components**

This function allows the user to update the properties of all components inserted in the current project when a version update has been executed. This function is active only when there is a difference between the application version that was used to create a file and the application version that opens that file.
3.1.2.8. **Window Menu**

3.1.2.8.1. **Windows Organization**

Automation Studio allows you to organize the display of projects and their diagrams in different windows. You can easily optimize the display of these windows while you design and simulate your project.

3.1.2.8.2. **Benefits from Multiwindowing**

The capability of Windows to simultaneously display multiple windows facilitates the exchange of information between the different open windows on your screen. In Automation Studio, this capability is a highly useful analysis tool for the following applications:

- To evaluate one or more diagrams during simulation;
- To highlight sections of the diagram whose behaviour under simulation is of particular interest.

This feature is useful when working on complex circuits contained on large-size diagrams or during the simulation of a project containing many diagrams. The following figure is an example of how a multiwindow display allows the user to view two different windows at the same time.
3.1.2.8.3. **Window Layout**

From the Window menu, you can organize the layout of open windows during your work session. The following is a description of the different commands in this menu. See the *Windows User's Guide* for more information on the organization of windows.

The Window menu comprises the commands related to organizing the layout of windows and duplicating the display of specific windows.
New Window

This command allows the user to open a new window that shows a different view of the current diagram.

Close All Windows

This command allows the user to close all the windows of the current project.

Display

This command allows the user to display the various utility programs for managing Automation Studio, as well as the toolbars the user may require to work.

- Toolbars…: This command allows the user to select the toolbars to be displayed on the screen. See section Toolbars to find out more about all the toolbars.
- Messages: This command allows the user to display the message window.
- Project Explorer: This command allows the user to display the Project Explorer.
- Library Explorer: This command allows the user to display the Library Explorer.
- Plotter: This command allows the user to display the Plotter.
- Status Bar: This command allows the user to display the Status Bar.
- Variables Explorer: This command allows the user to display the Variables Explorer.

**Horizontal Tile**

This command allows the user to display the various projects windows horizontally, whether they are active or not.

**Vertical Tile**

This command allows the user to display the various projects windows vertically, whether they are active or not.

**Cascade**

This command allows the user to display the windows of the various projects, whether they are active or not, one after the other with a slight gap between them.

**Open Project or Diagram Window**

This command allows the user to select the window of the project to display on top.

### 3.1.2.9. Help Menu

The Help menu comprises the commands related to the contextual help.

![Help menu](image)

*Figure 3–16: Help menu*

**Context Help**

This command opens the contextual help of the current window (Project, Library Explorer, etc.); or of the current element (component, group, DAO, etc.).
Help Content
This command opens the Table of Contents of the Automation Studio User’s Guide.

Software Registration
This command allows the user to register his or her copy of Automation Studio with Famic Technologies 2000 Inc. through the Internet.

Your workstation must be connected to the Internet to gain access to this service.

You must register your copy of Automation Studio to gain access to the online support.

Online Support
This command allows the user to gain access to the different Automation Studio Web services.

|---------------------|------------------|-----------------------------|-----------------------------|------------|

Figure 3–17: Online Support submenu

- **Client Support Page**: This command allows the user to gain access to his personal technical support portal.

Your version must be registered upon installation or by mail/fax or through the Software Registration command from the Help menu).

- **Discussion Forum**: This command allows the user to gain access to our online discussion forum regarding our software.

- **Frequently Asked Questions**: This command allows the user to gain access to a list of frequently asked questions. These questions came from Automation Studio users and
were answered primarily to inform Automation Studio users of recent developments, and secondly, to avoid answering the same questions repeatedly.

- Automation Studio on the Web: This command allows the user to gain access directly to the new features of the software.
- Suggestions: This command allows the user to gain access to a virtual suggestion box to which users may send suggestions via email.

About…

This command allows the users to view the information such as modules, system, identification, etc., which pertains to the installation of the software.

3.1.3. Toolbars

In order to display or hide a toolbar, choose Window → Display → Toolbars, then check or uncheck the toolbar. This command is also available through the F6 key or through a pop-up menu when the pointer is placed on top of any toolbar. To move a toolbar, click on the toolbar without releasing the mouse button, then move the mouse to where you want the toolbar to be released.

Project Toolbar

The Project toolbar contains all the buttons which correspond to the most utilized commands from the Project Explorer and Diagram Editor. The toolbar automatically adjusts itself to the functioning utility. When the command is unavailable in the utility, the button is greyed out and therefore inaccessible.

![Figure 3–18: Project toolbar](image)

The toolbar contains the following commands.

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>A</td>
<td>New Project</td>
</tr>
<tr>
<td>B</td>
<td>Open</td>
</tr>
</tbody>
</table>
Diagram Editor

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>C</td>
<td>Save</td>
</tr>
<tr>
<td>D</td>
<td>Print</td>
</tr>
<tr>
<td>E</td>
<td>New Diagram</td>
</tr>
<tr>
<td>F</td>
<td>New Report</td>
</tr>
<tr>
<td>G</td>
<td>New SFC</td>
</tr>
<tr>
<td>H</td>
<td>Project Explorer</td>
</tr>
<tr>
<td>I</td>
<td>Library Explorer</td>
</tr>
<tr>
<td>J</td>
<td>Variable Explorer</td>
</tr>
</tbody>
</table>

**Edit Toolbar**

The Edit toolbar of the Diagram Editor appears by default only if a diagram is active.

![Edit toolbar](image)

*Figure 3–19: Edit toolbar*

The toolbar contains the following commands.

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>A</td>
<td>Cut</td>
</tr>
<tr>
<td>B</td>
<td>Copy</td>
</tr>
<tr>
<td>C</td>
<td>Paste</td>
</tr>
<tr>
<td>D</td>
<td>Undo</td>
</tr>
<tr>
<td>E</td>
<td>Redo</td>
</tr>
<tr>
<td>F</td>
<td>Properties</td>
</tr>
</tbody>
</table>

Removes the selected object and stores it in the Clipboard.

Copies the selected object and stores it in the Clipboard.

Adds the content of the Clipboard onto the diagram.

Cancels the last executed action.

Reinstates the last cancelled command.

Displays the component’s Properties dialog box that introduces the selected item’s properties.
Simulation Toolbar

The Simulation toolbar of the Diagram Editor contains the following buttons.

![Simulation toolbar](image)

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>A Normal</td>
<td>Simulates a circuit in normal speed.</td>
</tr>
<tr>
<td>B Step by Step</td>
<td>Simulates a circuit where each mouse click corresponds to one cycle.</td>
</tr>
<tr>
<td>C Slow Motion</td>
<td>Simulates a circuit at the slowest speed.</td>
</tr>
<tr>
<td>D Pause</td>
<td>Interrupts the simulation.</td>
</tr>
<tr>
<td>E Stop</td>
<td>Stops the simulation.</td>
</tr>
<tr>
<td>F Project</td>
<td>Selects all of the current project’s diagrams when launching the simulation.</td>
</tr>
<tr>
<td>F Simulation</td>
<td></td>
</tr>
<tr>
<td>G Document</td>
<td>Selects the current diagram when launching the simulation.</td>
</tr>
<tr>
<td>G Simulation</td>
<td></td>
</tr>
<tr>
<td>H Selection</td>
<td>Selects the selected items when launching the simulation.</td>
</tr>
<tr>
<td>H Simulation</td>
<td></td>
</tr>
<tr>
<td>I Select Items</td>
<td>Opens the dialog box of diagrams to simulate in the current project.</td>
</tr>
<tr>
<td>I Simulate</td>
<td></td>
</tr>
<tr>
<td>J Plotter</td>
<td>Opens or closes the Plotter window.</td>
</tr>
</tbody>
</table>

View Toolbar

The View toolbar of the Diagram Editor contains the following buttons.

![View toolbar](image)
Diagram Editor

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>A</td>
<td>Zoom % Drop-down list allowing the selection of a predefined percentage of image magnification on the screen.</td>
</tr>
<tr>
<td>B</td>
<td>Zoom + Increases the image magnification of the diagram (maximum enlargement percentage of 800%).</td>
</tr>
<tr>
<td>C</td>
<td>Zoom - Reduces the image magnification of the diagram (minimum reduction percentage of 25%).</td>
</tr>
<tr>
<td>D</td>
<td>Window Zoom Allows the user to frame an area and enlarge it to display its magnification in proportion to the selected area.</td>
</tr>
<tr>
<td>E</td>
<td>Page Zoom Displays the whole of the diagram on the screen.</td>
</tr>
<tr>
<td>F</td>
<td>Zoom all Components Displays all items contained in the workspace.</td>
</tr>
<tr>
<td>G</td>
<td>Zoom Page Width Displays the page width wise.</td>
</tr>
<tr>
<td>H</td>
<td>Panning Moves into the panning mode.</td>
</tr>
</tbody>
</table>

**Insert Toolbar**

The Insert toolbar of the Diagram Editor contains the following buttons.

![Insert toolbar](image)

*Figure 3–22: Insert toolbar*

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>A</td>
<td>Selection Allows the selection of an item in the workspace.</td>
</tr>
<tr>
<td>B</td>
<td>Links Creates technological links.</td>
</tr>
<tr>
<td>C</td>
<td>Line Draws a line.</td>
</tr>
<tr>
<td>D</td>
<td>Rectangle Draws a rectangle.</td>
</tr>
<tr>
<td>E</td>
<td>Ellipse Draws an ellipse.</td>
</tr>
<tr>
<td>F</td>
<td>Arc Draws an arc.</td>
</tr>
<tr>
<td>G</td>
<td>Polygon Draws a polygon.</td>
</tr>
</tbody>
</table>

3-25
### Command Description

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>H</td>
<td>Text</td>
</tr>
<tr>
<td>I</td>
<td>Image</td>
</tr>
<tr>
<td>J</td>
<td>Field</td>
</tr>
</tbody>
</table>

### Layout Toolbar

The Layout toolbar of the Diagram Editor contains the following buttons.

![Figure 3–23: Layout toolbar](image)

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>A</td>
<td>Rotate Left 90°</td>
</tr>
<tr>
<td>B</td>
<td>Rotate Right 90°</td>
</tr>
<tr>
<td>C</td>
<td>Free Rotation</td>
</tr>
<tr>
<td>D</td>
<td>Vertical Flip</td>
</tr>
<tr>
<td>E</td>
<td>Horizontal Flip</td>
</tr>
<tr>
<td>F</td>
<td>Bring to Front</td>
</tr>
<tr>
<td>G</td>
<td>Send to Back</td>
</tr>
<tr>
<td>H</td>
<td>Group</td>
</tr>
<tr>
<td>I</td>
<td>Ungroup</td>
</tr>
<tr>
<td>J</td>
<td>Direct Link</td>
</tr>
<tr>
<td>K</td>
<td>Break Link</td>
</tr>
<tr>
<td>L</td>
<td>Join Links</td>
</tr>
<tr>
<td>M</td>
<td>Convert Link to Jumps</td>
</tr>
</tbody>
</table>
Format Toolbar

The Format toolbar of the Diagram Editor contains the following buttons.

![Format Toolbar](image)

*Figure 3–24: Format toolbar*

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>A Colour</td>
<td>Allows the user to modify the line colour of the selected graphic object, as well as the font colour of typed text on the diagram only.</td>
</tr>
<tr>
<td>B Thickness</td>
<td>Allows the user to modify the thickness of the line of the selected graphic object on the diagram only.</td>
</tr>
</tbody>
</table>

### 3.1.4. Status Bar

The status bar displays the description of menus and commands for each utility when selected by the user. It also contains different information slots displaying the current mode (Simulation or Editing), the status of specific keys (MAJ, NUM, DEF, INS). Furthermore, in the Diagram Editor, it informs the user on the pointer’s position in the diagram. The following information is displayed on the right-hand side of the Status bar.

![Status Bar](image)

*Figure 3–25: Status bar*

<table>
<thead>
<tr>
<th>Slot</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>ST XX :XX :XX.XX</td>
<td>Elapsed time from the start of the simulation.</td>
</tr>
<tr>
<td>X=XXX,Y=YYY</td>
<td>Indicates the pointer’s coordinates in the diagram.</td>
</tr>
<tr>
<td>X %</td>
<td>Indicates the zoom factor currently used in the diagram.</td>
</tr>
</tbody>
</table>

### 3.1.5. Plotter

The Plotter allows the user to see the evolution in time of various variables in a graphic window during simulation. Several variables of different components can be viewed simultaneously in a single graph.

One plotter is saved per project.
3.1.5.1. **Description of the Plotter**

The displayed values are established by default by the software. Some of them are modifiable while others remain static. The following list provides a short description of the data available in the Plotter and in its table of variables.

Each project has its own plotter.

<table>
<thead>
<tr>
<th>Zone</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>A Scale</td>
<td>Displays the Y-axis (ordinates) of each selected variable.</td>
</tr>
<tr>
<td>B Graph</td>
<td>Plotting area of the evolution curves.</td>
</tr>
<tr>
<td>C Properties list</td>
<td>Modifiable display of the list of properties of variables.</td>
</tr>
</tbody>
</table>

*Figure 3–26: Plotter*
<table>
<thead>
<tr>
<th>Zone</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>D</td>
<td>Component Displays the internal identifier in the list. This value is static.</td>
</tr>
<tr>
<td>E</td>
<td>Name Displays the name of the component. This value is static.</td>
</tr>
<tr>
<td>F</td>
<td>Variable (Plot) Displays the name of the variable. This value is static.</td>
</tr>
<tr>
<td>G</td>
<td>Colour Displays the colours, defined by default, which identify the variable and its curve. This colour is modifiable.</td>
</tr>
<tr>
<td>H</td>
<td>Min. Scale Displays the minimal traceable value of the associated variable. A value is assigned to each variable by default. This value is modifiable.</td>
</tr>
<tr>
<td>I</td>
<td>Max. Scale Displays the maximal traceable value of the associated variable. A value is assigned to each variable by default. This value is modifiable.</td>
</tr>
<tr>
<td>J</td>
<td>Current unit Displays the component’s measure unit value. This value is static.</td>
</tr>
<tr>
<td>K</td>
<td>Interval-Time Displays the value of the time interval visible on the graph for all the traced variables. This value appears in seconds and is modifiable.</td>
</tr>
<tr>
<td>L</td>
<td>Export Allows the user to export the curves in a tabulated .txt format.</td>
</tr>
<tr>
<td>M</td>
<td>Help Displays the help text of this dialog box.</td>
</tr>
<tr>
<td>N</td>
<td>Properties Button allowing access to the list of modifiable and static properties of variables.</td>
</tr>
<tr>
<td>O</td>
<td>Apply Allows the user to execute a modification or a deletion and apply it to the graph and scale. This button may be used for each modification or once for all of the modifications.</td>
</tr>
<tr>
<td>P</td>
<td>Delete Allows the user to remove a selected variable in the list.</td>
</tr>
<tr>
<td>Q</td>
<td>Cancel Allows the user to invalidate a previously executed modification or deletion.</td>
</tr>
</tbody>
</table>

### 3.1.6. Message Window

This window opens automatically to inform the user of any detected errors that require correction.
3.2. Management Utilities

The management utilities are used to manage projects. Each of these utilities offers users the possibility of managing projects based on their requirements, whether it is for variable management or component library creation.

To display or hide the management utilities, do the following:

1. Select Window → View.

Automation Studio opens the list of utilities to be displayed or hidden. When the name of a utility is preceded by a checkmark, it means that it is actually being displayed on the screen.

Figure 3–15: Display submenu shows all the utilities available in Automation Studio. Each of these utilities is described in the following pages.

In order to optimize the workspace, every utility window is supplied with this “Thumbtack” that, when in this position, allows windows to automatically roll up. Once rolled up, these windows only show their title bar when the pointer leaves their area. To avoid having these windows roll on themselves, the “thumbtack” button must be in this position.

3.2.1. Library Explorer

The Library Explorer offers a wide variety of hydraulic, pneumatic, control command components, etc. It allows the selection of all necessary elements for the construction of a functional circuit. It also allows the user to create and manage new libraries and new component based on the user’s requirements.
The elements composing the Library Explorer are as follows:

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>A</td>
<td>Toolbar</td>
</tr>
<tr>
<td>B</td>
<td>Tab(s)</td>
</tr>
</tbody>
</table>
Command | Description
--- | ---
C | Library window | The library window allows the user to display the tree and select subgroups, and specialized workshop families such as hydraulics, pneumatics, etc. Each type of library contains the related components.
D | Component window | The component library allows the user to display and select the components necessary to create a circuit.

### 3.2.1.1. Library Explorer’s Toolbar

The Library Explorer’s toolbar of the Diagram Editor contains the following buttons.

![Figure 3–28: Library Explorer toolbar](image)

Command | Description
--- | ---
A | Open library | Allows the user to select one of the libraries available, either the standard or customized libraries.
B | Create library | Allows the user to create a library that can be customized based on the project requirements.
C | Save library | Allows the user to save the libraries that have been customized based on the project requirements.
D | Create category | Allows the user to create a category of components that can be customized based on the project requirements.
E | Delete category | Allows the user to delete a category of components. This option applies only to categories created by the user and not to categories supplied with Automation Studio.
F | Lock/Unlock | Allows the user to lock/unlock a library in order to protect it from being deleted by mistake.

### 3.2.2. Project Explorer

The Project Explorer controls all the functions related to the management of opened projects and their documents. Because of pop-up menus related to the selected document, it allows to create, display, save, export/import, send to, and simulate a document as well as to print it in parts or in whole.
## 3.2.3. Variable Manager

The Variable Manager offers the user the ability to filter, modify, view, and link to OPC items all the variables contained in the active project. It also allows creating and deleting internal variables.

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>A</td>
<td>Tree window Allows the user to select elements from the tree of a project and to apply an action to the selected element (printing, copying, renaming, etc.).</td>
</tr>
</tbody>
</table>

To obtain the maximum use from the software, it is strongly suggested that you manage projects or files through the File menu of the main window, and manage documents through pop-up menus from the Project Explorer.
### Command Description

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>A Filter</td>
<td>Allows the user to sort out variables based on a specific character chain. Variables with a mnemonic containing the character chain defined as filter are sorted out to be displayed.</td>
</tr>
<tr>
<td>B Update</td>
<td>In editing mode, this button allows refreshing the variable list following the addition or deletion of internal variables or components. While in simulation mode, allows the user to update the value of variables.</td>
</tr>
<tr>
<td>C New Variable</td>
<td>Allows the user to create a new internal variable. See Adding a Variable</td>
</tr>
<tr>
<td>D Modify Variable</td>
<td>Allows the user to modify a variable’s properties. See Modifying a Variable</td>
</tr>
<tr>
<td>E Delete Variable</td>
<td>Allows the user to delete an internal variable. Does not allow the user to suppress a component’s variable.</td>
</tr>
<tr>
<td>F OPC Links</td>
<td>Opens the dialog box used to create read/write links to OPC items. See Creating an External Link.</td>
</tr>
<tr>
<td>G Variable List</td>
<td>Displays the project’s variables based on the current filter.</td>
</tr>
<tr>
<td>H Help</td>
<td>Opens the contextual help.</td>
</tr>
<tr>
<td>I Close</td>
<td>Shuts the Variable Manager’s window.</td>
</tr>
</tbody>
</table>

#### 3.2.3.1. Adding a Variable

To create an internal variable:

1. Click on the New Variable button (in the Variable Manager window or in the Ladder of SFC’s Component Properties dialog box).

The OPC Settings dialog box opens.

2. Fill in the various fields.

3. Click OK.
You can only create internal variables. Components’ variables are automatically created when components are created.

The tag name of the variable must not contain spaces and must start with a letter or a number. It must include at least one letter. It must be unique in the project or document based on the global or local link of the variable. Reserved names must not be used (ABS, SQR, etc.).

The address must respect the manufacturer’s syntax and be unique in the project.

Figure 3–31: Add a Variable dialog box

The following is a description of the fields composing this dialog box.

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>A Tag Name</td>
<td>Displays the variable’s tag name and allows it to be modified if the field is not greyed out.</td>
</tr>
<tr>
<td>B Address</td>
<td>Allows typing in the variable’s address when it is a PLC variable.</td>
</tr>
</tbody>
</table>
### Field Description

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
</table>
| C     | Variable Type | This drop-down list allowing the selection of one of the following types of variable:  
  - Generic Boolean;  
  - Integer (32 bits);  
  - Float (32 bits). |
| D     | Document     | This drop-down list allowing to specify whether the variable is global for the current project or local for a document:  
  - Project (global);  
  - Diagram name (locale for a diagram or SFC). |
| E     | Description  | Allows the user to type in a comment related to the variable. |

#### 3.2.3.2. Modifying a Variable

To modify the name, initial value, address, or description of a selected variable:

1. Select the variable you wish to modify and click the Modify Variable button or double-click the line containing the variable.

   The Modify Variable dialog box opens.

2. Modify the necessary fields.

3. Click the OK button.

   The Modify Variable dialog box closes.

   The new properties are saved and updated.

   All diagrams in which the modified variable appears are also updated with the new properties.

- Only variables of transmitter, transmitter/receiver components may be modified. Fields are greyed out for variables of receiver components.

- A variable’s tag name must start with a letter or a number and it must not contain a space. The name must contain at least one letter. The variable’s tag name must be unique in the project or document depending on the link (global or local) of the variable. Reserved names must not be used (ABS, SQR, etc.).
The address must respect the manufacturer’s syntax and be unique in the project.

It is possible to modify the link (affiliation document) of a variable.

![Modify Variable dialog box](image)

**Figure 3–32: Modify Variable dialog box**

Here is a description of the available fields in the Modify Variable dialog box:

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>A</td>
<td>Tag Name Displays the variable’s tag name and allows it to be modified if</td>
</tr>
<tr>
<td></td>
<td>the field is not greyed out.</td>
</tr>
<tr>
<td>B</td>
<td>Value Allows typing in an initial value for the variable.</td>
</tr>
<tr>
<td>C</td>
<td>Hexadecimal/Binary These fields allow converting whole numbers into</td>
</tr>
<tr>
<td></td>
<td>hexadecimal and binary numbers.</td>
</tr>
<tr>
<td>D</td>
<td>Address</td>
</tr>
<tr>
<td>E</td>
<td>Description</td>
</tr>
</tbody>
</table>

These fields allow converting whole numbers into hexadecimal and binary numbers.
### 3.2.3.3. Sorting Variables

To sort variables:

1. Click on the header of a column in the table. The variables in that column are alphabetically sorted.
2. Click on the header of the same column a second time and the order of the variables is reversed.

### 3.2.3.4. Filtering Variables

To filter variables:

1. Type in a character string. This string must begin by either a letter or a number. It must also contain at least two characters one of which must be a letter. It must not contain any spaces.
2. Only variables containing this character string will be displayed in the table.

### 3.2.3.5. Supervising Variables’ Values in Simulation Mode

You may find yourself in a situation where a circuit is not behaving the way it’s intended to. To solve this problem, the Variable Manager allows viewing the component’s status by displaying their variables’ values. This allows identifying components and variables which are not behaving properly.

To view the variables’ values:

1. Start the simulation.
2. Filter and sort the variables if necessary.
3. Adjust the size of the Variable Manager window if necessary.
4. Click the Update button to force a regeneration of the variables’ values.

---

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>D Address</td>
<td>Allows the user to type in the variable’s address when it is a PLC variable.</td>
</tr>
<tr>
<td>E Description</td>
<td>Allows the user to type in a comment related to the variable.</td>
</tr>
</tbody>
</table>
Only variables that can act as a transmitter, transmitter/receiver, or receiver can be viewed in the Variable Manager. For other variables (pressure, flow, etc.), refer to Plotter.

### 3.3. Pop-up/Contextual Menus

The Diagram Editor’s pop-up menus were created in order to facilitate access to tool and menu bars. With the exception of a few commands specifically created for specific cases, all commands found in the pop-up menus are either in the tool or the menu bars.

#### 3.3.1. Open a pop-up Menu

Pop-up menus are displayed when the user clicks on the right mouse button the pointer is placed on an element within the Diagram Editor. The pop-up menu of this element opens on the screen and the user may then choose the available command from this menu.

#### 3.3.2. Pop-up Menus’ Specific Commands

Some of the commands are available only through pop-up menus. They are not accessible neither by standard menus, nor by button bar. These commands apply specifically to the selected item or to the current context.

##### 3.3.2.1. Fluid Link in Edit Mode

**Drain**

This command applies to the hydraulic link in the Diagram Editor as prescribed by the ISO standards.

**Pilot**

This command applies to the hydraulic and pneumatic links in the Diagram Editor as prescribed by ISO standards.

**Pressure**

This command applies to the hydraulic and pneumatic links in the Diagram Editor as prescribed by the ISO standards.
3.3.2.2. Symbol in Simulation

Animation
This command applies to the components in the Diagram Editor while in Simulation mode. It allows the user to open the window in order to see the synchronized cross-section view of the component.

Setting
This command allows the user to modify the functional adjustment setting (e.g.: valve opening pressure) applied to components while in the simulation mode.

3.3.2.3. Symbol Area in the Library Explorer

Small/Medium/large Icons
This command applies to the components in the Library Explorer. It allows the user to determine the display size of the components within the library’s symbol window.

Rename
This command applies to the new components, libraries, and categories in the Library Explorer and to projects and diagrams in the Project Explorer. It allows giving a different name to the selected element other than the one given automatically by the software. Therefore, the user is free to rename his or her documents and work tools as he/she sees fit based on the project’s needs.
4. Creation and Management of a Project and its Documents

This chapter describes the instructions required for the creation and management of projects within the Project Explorer.

This chapter covers the following topics:

- Management of projects (files created by Automation Studio) and of their documents;
- Management of documents from a project.

4.1. Creation of a New Project

To create a new project:


The Project Templates dialog box opens and offers a selection of templates to choose from and on which the user can base his new project.

![Figure 4–1: Project Templates dialog box](image)
2. Choose the desired template or choose None if none of the templates available correspond to your needs.

3. Once your selection has been completed, click on the OK button to create the new project.

A new project identical to the selected model opens on the screen as well as in the Project Explorer. By default, it has an assigned name that may be changed as you wish. By default, the software includes a blank diagram within the new project.

You may now include documents of your choice in the new project. (For more details on how to manage diagrams, see the Creating a New Document section.)

### 4.1.1. Saving a New Project

When a project is created, by default it is labelled with a sequential name. To save the new project, execute the following steps:

1. Select File → Save Project as.

The Save As dialog box appears on the screen.

![Figure 4–2: Save as dialog box](image)

2. Type in the new name of the file in the File name field.

3. Select the desired directory from the Save in drop-down list.

4. Click Save.
The Project Properties dialog box opens on the screen and displays the Summary Info branch. The information from the Project Properties dialog box may be modified at any time. You may fill it out now and modify it later.

This property may be used in automatic fields.

To complete the procedure for saving a new project:

5. Click OK.

The new document has been created and is ready to receive all the elements and modifications you wish to include.

### 4.1.2. Opening a Project

To open a project:

1. Choose File → Open.

The Open dialog box appears on the screen.

![Open dialog box](image)

*Figure 4–3: Open dialog box*
2. From the Drives and Directory lists, select the disk and directory containing the project.
3. In the File name list, select the project you wish to open.
4. Click on the Open button.

4.1.3. Closing a Project

To close a project:


If no modification has been executed since the last time the project was saved, the software closes the current project.

If modifications were executed since the last time the project was saved, a message appears on the screen requiring confirmation to save the last modifications.

2. If you wish to save the modifications, click on the Yes button.

If the project has already been saved under a specific name, a new save is automatically executed.

If the project was never saved, the Save As dialog box will automatically open. See section Saving a New Project for the procedure.

3. If you do not wish to save the last modifications, click on the No button.

The software closes the project and the most recent modifications are lost.

The Project Explorer no longer holds that project.

4.2. Creating a New Document

It is possible to include different types of documents within a project. These different types include diagrams integrating components from standard workshops, documents integrating components from non standard workshops, reports, documents coming from external applications such as Web pages, word-processing documents, spreadsheets, etc.

4.2.1. Creating a New Diagram

To create a new diagram:


The Diagram Templates dialog box opens on the screen.
2. Select the template corresponding to your requirements. If none of the templates corresponds, select the None template and modify it according to your needs.

3. Click OK.

You may create a new diagram containing all your requirements and save it as a template. See section Saving a Template for the procedure.

A diagram template may contain draw elements, a header, components, and images. See Inserting a Graphic Element section for inserting fields, graphic elements, and images in a diagram).

4.2.2. Creating a Sequential Functional Chart (Non Standard Workshop)

If you have the required license for a non standard workshop:

1. Choose File → New → Sequential Functional Chart. From the toolbar, this button is associated to a new SFC for this example.
The SFC Templates dialog box appears on the screen.
2. Select the desired templates by clicking on its icon.
3. Click on the OK button to confirm.
The SFC Properties dialog box opens on the screen.
The new document opens and incorporates itself into the Project Explorer at the desired location.

4.2.3. Creating a New Report

To create a new report:

⚠️ You must possess the required license to have access to the Advanced Report module. Choose the About command from the Help menu to find out more about your license.

1. Choose File \(\rightarrow\) New \(\rightarrow\) Report.

The Report Templates dialog box appears on the screen.
2. Select the template corresponding to your requirements. If none of the templates can be used, select None and modify it according to your needs.
3. Click OK.
The Report Configuration dialog box appears on the screen.
4. Select the data that corresponds to your needs.
5. Click OK

⚠️ For more details, refer to the Creating a New Report section.

4.2.4. Inserting a Web Page

To insert a Web page:

1. Choose File \(\rightarrow\) New \(\rightarrow\) Web Page.

The Web Page Address dialog box requesting the URL (the address) as well as the name to be given to this new document appears on the screen.
2. Type in the name and URL of the Web page in the appropriate fields.
3. Click the OK button to confirm.
The Web page opens and incorporates itself into the Project Explorer at the desired location.

### 4.2.5. Inserting a New External Document

To insert a new external document:

1. Choose File → New → Other document.

The Insert Active Document dialog box opens and lists all the different types of available documents.

2. You can create a blank document by selecting the New option or use an existing document by selecting the From File option in which case the dialog box displays a button that brings you to the File Manager of the operating system.

The New option:

1. Select the application from which you intend to create the new document.
2. Click OK.
The selected application opens on the screen while keeping Automation Studio running in the background
3. Create your new document.
The new document opens and incorporates itself in the Project Explorer at the desired location. To return to Automation Studio:

4. Double-click on one of the AS diagrams.
Automation Studio re-emerges on the foreground.

The From File option:

1. Click on the Browse button.
The Browse dialog box appears on the screen.
2. Select the desired directory and file.
3. Click Open.
The Insert Active Document dialog box reappears on the screen.
4. Click OK.
The new document opens and incorporates itself into the Project Explorer at the desired location. To return to Automation Studio:

5. Double-click on one of the AS diagrams.

Automation Studio re-emerges on the foreground.

4.2.6. New Folder


The new folder is create and inserted into the Project Explorer’s tree structure.

4.3. Saving a Template

If you frequently use the same project structure or the same items in diagrams (images, cartridges, etc.) or the same information in reports, it is then useful to create templates of documents and projects. Thus, when creating a new project, diagram or report, the document configuration doesn’t have to be redone.

In order to ensure that all the models remain accessible, it is important that they be saved/stored in the Template directory of Automation Studio. If these templates are saved in another directory the software will not be able to access them on start-up.

4.3.1. Project Template

The project template holds a specific structure of preconfigured documents as well as customized property fields. To save a project as a template, the project itself must be active.

1. Choose File → Save Template As → Project.

The Save Template As dialog box opens

2. Enter a name and description for the template.

3. Click on the Save button to validate.

The Project Properties dialog box opens.

4. Fill out the necessary fields for the identification of the template (optional).

5. Click OK.
A project template with the name given earlier is created with the .PJT extension in the Templates folder.

### 4.3.2. Diagram Template

The diagram template allows saving the page layout parameters as well as the diagram properties. To save a diagram template:

1. Choose File → Save Template As → Diagram.

The Save Diagram Template dialog box opens.

2. Enter a name and description for the template.

3. Click on the Save button to validate.

A diagram template with the name given earlier is created with the .SCT extension in the Templates folder.

### 4.3.3. Report Template

You must possess the required license to gain access to the Advanced Report module. Choose the About command from the Help menu for more information on your license.

A report template contains the component, workshop, and information fields’ filters. To save a report template:


The Save Report Template dialog box opens.

2. Enter a name and description for the template.

3. Click on the Save button to validate.

A report template with the name given earlier is created with the .RPT extension in the Templates folder.
4.4. **Saving a Project**

To save a project:

1. Choose File → Save.

The project is saved.

Each time this command is called upon, the active project’s file is saved with the modifications performed since the last save.

If this is the first time you are saving the active project, the Save As dialog box automatically opens. (For more details on this dialog box, refer to the Saving a New Project section.)

4.4.1. **Project Save As**

Every project may be saved under a different name. Refer to the Saving a New Project section for the procedure to follow.

4.5. **Project Properties**

Some properties, along with the different revisions of the project are accessible through automatic fields allowing the creation of dynamic cartridges on diagrams.

There is, for each of your projects, a properties dialog box containing the identification and information related to the project management. The General branch contains the data that is automatically managed by the operating system and presents users with static information about the project.

The Summary Info and History branches allow the user to enter the necessary information for the identification and project management.

To open the Project Properties dialog box:


The dialog box opens.

2. Select the desired branch.
4.5.1. General Branch

The General branch informs the user on the project’s type, location, size, MS-DOS name, creation and modification date, and last access date. It also informs of the project’s attributes such as Read-Only, Archive, Hidden, and System.

4.5.2. Summary Info Branch

The Summary Info branch allows the user to enter any information that is relevant to the active project. This information may be entered at any time and is modifiable at any time as the project progresses.

To enter and modify the project’s summary information:


The Project Properties dialog box opens.

2. Select the Summary Info branch.

![Figure 4–5: Project Properties dialog box, Summary Info branch](image)

Figure 4–5: Project Properties dialog box, Summary Info branch
3. Type in or modify the various fields of the dialog box.
4. Click the Apply button to validate the information.

The data entered or modified in the Summary Info branch are validated.
5. Click the Close button to exit the dialog box.

Here is a description of the available fields in the Summary Info branch:

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Displays the given name of the project.</td>
</tr>
<tr>
<td>Title</td>
<td>Displays the title of the project.</td>
</tr>
<tr>
<td>Subject</td>
<td>Allows the user to type in a short description of the project.</td>
</tr>
<tr>
<td>Document No.</td>
<td>Displays the number given to the project.</td>
</tr>
<tr>
<td>Company</td>
<td>Displays the name of the company related to the project.</td>
</tr>
<tr>
<td>Drawn by</td>
<td>Displays the name of the author of the project.</td>
</tr>
<tr>
<td>Verified by</td>
<td>Allows the user to enter the name of the person responsible for verifying the project.</td>
</tr>
<tr>
<td>Approved by</td>
<td>Allows the user to enter the name of the person responsible for approving the project.</td>
</tr>
<tr>
<td>Category</td>
<td>Displays the type of project.</td>
</tr>
<tr>
<td>Keywords</td>
<td>Allows entering keywords related to the project.</td>
</tr>
<tr>
<td>Comments</td>
<td>Allows the user to enter detailed comments including important information and notes for this project. The first line of comments entered will also be displayed in the Description field of the Open dialog box when this project is subsequently selected and opened.</td>
</tr>
<tr>
<td>Template</td>
<td>Displays the name of the template on which the project is based. It is not modifiable.</td>
</tr>
</tbody>
</table>

Entered information in the Summary Info branch may be inserted in a field on a diagram to create the cartridge information. For more details, refer to the Inserting a Text Box, a Picture, and a Field section.
4.5.3. **History Branch**

The History branch allows the user to enter comments and information on different phases of the current project’s progression. The user may assign sequential revision numbers to identify the project phases. The first comment is automatically saved and subsequent revision numbers, their revision dates, comments, the author’s name, and the company’s name are also saved.

![Figure 4–6: Project Properties dialog box, History branch](image)

4.5.3.1. **Add/Modify a Revision**

The New Revision button is always available for the current project and is used only to add a new revision.

To add a new revision:


   The Project Properties dialog box opens.
2. Select the History branch.
3. Click on the New Revision button.
The fields are emptied of all previous information.
4. Fill out the necessary fields.
5. Click the Apply button to validate the information.

To modify the information within a revision:
1. Open the Revision drop-down list and select the revision to be modified.
The data entered in the revision is displayed on the screen.
2. Modify the necessary fields.
3. Click the Apply button to validate the modification.
4. Click the Close button to exit the dialog box.

Here is a description of the available fields in the History branch:

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Created</td>
<td>Displays the project’s time and date of creation. This field cannot be modified.</td>
</tr>
<tr>
<td>Modified</td>
<td>Displays the project’s time and date of last save function. This field is updated on the most recent project save action.</td>
</tr>
<tr>
<td>Revision</td>
<td>Allows the user to name or select a new or previous revision, then to enter or display that revision’s information.</td>
</tr>
<tr>
<td>New Revision</td>
<td>Allows the user to create a new revision.</td>
</tr>
<tr>
<td>Revision Comment</td>
<td>Displays the comments of each revision of the project.</td>
</tr>
<tr>
<td>Revised by</td>
<td>Allows the user to enter the name of the proof-reader associated with the project.</td>
</tr>
<tr>
<td>Verified by</td>
<td>Allows the user to enter the name of the person responsible for verifying the project.</td>
</tr>
<tr>
<td>Approved by</td>
<td>Allows the user to enter the name of the person responsible for approving the project.</td>
</tr>
<tr>
<td>Date</td>
<td>The three Date fields allow the user to enter the different revision dates.</td>
</tr>
</tbody>
</table>
4.6. **Print**

To print more than one document in the current project:

1. Choose File → Print (CTRL + P).

The Items for Print Preview and Print dialog box opens.

2. Check the boxes of the documents you wish to print.

To print the complete project, check the project box. The documents’ checkbox will automatically be selected.

3. Click OK to validate.

The Print Setup dialog box opens.

4. Define the print options you wish to use.

5. Click OK to validate.

### 4.6.1. **Print Preview**

In order to avoid unnecessary printouts of documents, it is to your advantage to preview the document before sending the print command. To preview a document in a project:


The Items for Print Preview and Print dialog box opens.
2. Check the box of the documents you wish to preview.

To preview the complete project, check the project box. The documents’ checkbox will automatically be selected.

3. Click on OK to validate.
The Print Setup dialog box opens.
4. Click on OK to validate.
The Print Preview window opens.
To exit the Print Preview window:
5. Click on the Close button, use the Esc key, or click on the Print button.
4.7. **Exporting a Diagram**

To export a diagram from the current project:


   The Save As dialog box opens.

2. Choose the destination of the project to export.

3. Choose the format in which you wish to export the project (DXF or EMF).

4. Click OK to validate.

4.8. **Sending a Project To**

To send the current project:

1. Choose File → Send To.
Your email software must be installed and configured.

The Project Properties dialog box opens.
2. Fill in the information you wish to send along with the project.
3. Click OK to validate.

4.9. Exiting from the Application

To exit the software:
1. Choose File → Exit (ALT + F4).

If no modifications have been executed since the last save, the software closes and terminates the exit procedure.

If modifications have been executed since the last save action, the next Confirmation dialog box opens automatically for each opened project.

![Figure 4–9: Confirmation dialog box]

2. If you do not wish to save modifications, click the No button.

The software closes without saving the last modifications and terminates the exit procedure.
3. If you wish to save the modifications, click the Yes button.

If the project has previously been saved, this new save action automatically replaces the previous save action. The software closes and terminates the exit procedure.

If the project has never been saved, the Save As dialog box automatically opens.
4. Enter the required information and click OK.

For more information on the Save As dialog box, refer to the Saving a New Project section.
5. Repeat this procedure for each and every opened project.
5. Creating a Diagram

This chapter describes the instructions that are required for the creation of a diagram within the Diagram Editor.

This chapter covers the following topics:

- Page layout;
- Setting elements within a diagram;
- Component properties;
- Component preview;
- Modification of a diagram;
- Simulation.

To begin the creation of a diagram, you must first start the software as per section Starting Automation Studio.

5.1. Document Properties

This dialog box is both common and customized for each document it is associated to. The page setup, history and summary info follow-up functions are common for both diagrams and SFCs. The Diagram and SFC branches are customized based on the type of document this dialog box is associated with. Furthermore, the data entered in the fields is customized according to the current document’s specifications.

5.1.1. Page Setup Branch

The workspace corresponds to the available space for the creation of a diagram. Several parameters are associated the work page. For example, you can select its orientation and size, you can also add additional elements to your diagram such as a frame, a cartridge, a BOM, and/or a map locator.

🔍 The work sheet (white) corresponds to the printable area of the diagram.

The Page Setup branch of the Document Properties command of the Edit menu allows you to define the work sheet’s height and width and how you wish to print your diagram.
Since incorporating these elements reduces the space available for creating your diagram, it is strongly recommended that you define the page setup before creating your diagram.

![Map locator inserted in the diagram](image)

Figure 5–1: Map locator inserted in the diagram

You can customize the workspace of the Diagram Editor in order for it to correspond to your requirements and preferences.

To define or modify the page setup of a diagram:


The Document Properties dialog box opens.

2. Enter or modify the various fields in the dialog box.

3. Click on the Apply button to validate.
The new information entered in the dialog box is validated.

4. Click on the Close button to return to your diagram.

The new page setup you have just defined is validated. The additional elements are now displayed in your work sheet.

![Document Properties dialog box, Page Setup branch](image)

**5.1.1.1. Description of Page Setup Options**

Here is a description of the available fields in the Page Setup branch:

<table>
<thead>
<tr>
<th>Zone</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>A</td>
<td>Diagram Size</td>
</tr>
<tr>
<td>B</td>
<td>Margins</td>
</tr>
</tbody>
</table>
### Zone Description

<table>
<thead>
<tr>
<th>Zone</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>C</td>
<td><strong>Orientation</strong> Allows the user to select the orientation of the work sheet, either Portrait (height-wise) or Landscape (width-wise).</td>
</tr>
<tr>
<td>D</td>
<td><strong>Ruler Units</strong> Allows the user to select between the metric or imperial unit systems to display the measurement units of the map locator.</td>
</tr>
<tr>
<td>E</td>
<td><strong>Drawing Scale</strong> Allows the user to define the proportional resizing of elements inserted in the diagram.</td>
</tr>
<tr>
<td>F</td>
<td><strong>Map Locator</strong> Adds an alphanumerically dotted grid within the work sheet of the diagram.</td>
</tr>
</tbody>
</table>

Do not confuse the grid from the View menu which is used to snap objects, and the map locator grid which is used to locate objects within the diagram.

### 5.1.2. Summary Info Branch

The document Summary Info branch contains data used for the identification of each document making up your project.

1. Select the diagram for which you wish to enter or modify the information.

To edit and/or modify the current document’s properties:


The Document Properties dialog box opens.

2. Enter or modify the data contained within the fields of the Summary Info branch.

3. Click on the Apply button.

The data is validated.

4. Click on the Close button to return to your diagram.
Here is a description of the available fields in the Summary Info branch:

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Displays the given name of the document.</td>
</tr>
<tr>
<td>Title</td>
<td>Displays the title of the document.</td>
</tr>
<tr>
<td>Subject</td>
<td>Allows the user to enter in a short description of the document.</td>
</tr>
<tr>
<td>Document No.</td>
<td>Allows the user to enter the ID number you wish to attribute to the document.</td>
</tr>
<tr>
<td>Company</td>
<td>Displays the name of the company related to the document.</td>
</tr>
<tr>
<td>Drawn by</td>
<td>Displays the name of the author of the document.</td>
</tr>
<tr>
<td>Verified by</td>
<td>Allows the user to enter the name of the person responsible for verifying the document.</td>
</tr>
</tbody>
</table>
Field | Description
--- | ---
Approved by | Allows the user to enter the name of the person responsible for approving the document.
Category | Displays the type of project.
Keywords | Allows the user to enter keywords related to the document.
Comments | Allows the user to enter detailed comments including important information and notes for this document.
Template | Displays the name of the template on which this document is based on. It is not modifiable.

5.1.3. **Diagram Branch**

This branch of the Document Properties is used to define an additional identifier to projects using multiple diagrams.

![Diagram Branch](image)

*Figure 5–4: Document Properties dialog box, Diagram branch*
<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Allows the user to enter a name for the document.</td>
</tr>
<tr>
<td>Installation</td>
<td>1219-2 Standard: This code is made up of numbers that start with 1. This installation number or functional group must be used as soon as the circuit includes any installation.</td>
</tr>
<tr>
<td>Circuit</td>
<td>1219-2 standard: This code is made up of numbers. The numbering is executed continuously for each circuit.</td>
</tr>
</tbody>
</table>

### 5.1.4. History Branch

The History branch allows the user to enter comments and information on different phases of the current document’s progression. The user may assign sequential revision number to identify the project phases. The first comment is permanently saved, and subsequent revision numbers along with their revision date, comments, the author’s name, and the company’s name are re-written every time the project is saved.

![Figure 5–5: Document Properties dialog box, History branch](image)

*Figure 5–5: Document Properties dialog box, History branch*
Given that the Document Properties and Project Properties dialog boxes display identical fields, refer to the History Branch section for a detailed description of each available field that is defined for each document.

5.2. Layout of Elements Within a Diagram

5.2.1. Layout of Components and Use of Library

The selection of a component to insert within a diagram is done from a library. Occasionally, the insertion of a component is followed by the opening of its Component Properties dialog box, especially when these components communicate amongst themselves through mnemonics in simulation mode (a coil and its contacts).

The component’s properties allow the user to define behaviour parameters of the component within a diagram. Properties may relate to the component’s in and out sizes, to its internal behaviour, or its dimensions.

There is a Component Properties dialog box for each component. Since many components are simple and similar, their Component Properties dialog box will be identical.

The components’ properties are described in detail in the user guide of the specific workshop, or in the on-line help of the component’s properties dialog box or contextual help (F1). The detailed description of properties for each component can be found in the on-line help of the symbol which is accessible through the Help button of the various property branches.

All the components’ parameters in the Fluids workshop are preconfigured in such a way that the simulation should work properly without any intervention from the user. Communication variables from the Control workshop are the only exception to this rule.

To insert a component within your diagram:

1. If the Library Explorer is not opened, press the F9 key to open it.
   The Library Explorer window opens.

2. Select the specific library by clicking on its tab.

3. Click on the workshop of your choice in the Workshop list.
   The list of available categories from the selected workshop opens.

4. Click on the category containing the specific component you wish to use.
   The components list opens in the symbol window.

5. Click on the symbol without releasing the button.
The component’s symbol is highlighted.
6. Slide the pointer to the location where you wish to insert the symbol.

The pointer takes this shape 🔄.
7. Release the button.

The symbol is set on the diagram.
8. If the component’s properties dialog box opens, define its parameters.
9. Click on the Apply button, then on the Close button.

Parameters defined for this component are now validated. To show the displayable properties on the diagram, refer to the symbol’s Displayed Information. Once the information is displayed on the diagram, it is possible to format its font, size, colour, etc. simply by double-clicking it. The Font dialog box opens and allows you to define the format of the information on the diagram just as if it were a Text object.

### 5.2.2. Layout of Links

Links, just like electrical wires or circuit lines, allow the joining of components.

To set up a link:
1. Click on one of the symbol’s connection ports.

The mouse pointer takes this shape 🔄.
2. Click in different locations on the diagram to create elbows thus avoiding going over other elements already in place.

In this situation, the mouse pointer takes this shape 🔄.

The link is traced as you slide the pointer.
3. Release the mouse button when you reach the second connection port and the pointer will return to this shape 🔄 again.

The link is established between the two components.
4. Repeat step 1 through 3 for each link you wish to insert. It is not necessary to reselect the link tool.
5. To stop drawing links, click at any time and anywhere in the diagram with the right mouse button.

The mouse pointer reverts to its initial shape.
Displaying connections may be quite useful for this procedure. It allows the user to visualize the overlapping of connection ports. To display them, ensure that the Connection Ports option is checked in the View menu.

You can modify the shape of a link once it's inserted. To learn how, refer to the Modifying the Shape of a Link section.)

5.2.2.1. **Automatically Processing Intersections**

When a 3-way junction is created, a black connector is automatically created as required by ISO standards.

5.2.2.2. **Moving Connection Ports**

To move a connection port:

1. Select the link whose connection you wish to move.

The link assumes the selection colour.

2. Click on the connection to be modified and, without releasing the mouse button, slide the pointer to the new connection port.

The mouse pointer takes this shape 📌. The link is modified as you slide the pointer.

3. Release the mouse button once the two connections overlap.

5.2.2.3. **Moving a Link**

To move a link that is connected or not:

1. Select the link you wish to move.

The link assumes the selection colour.
2. If the link is a direct link, click in the centre of the link. Otherwise, click on a corner of
   the link.

   The mouse pointer takes this shape \( \uparrow \rightarrow \).

3. Without releasing the mouse button, slide the pointer to the new location on the diagram.

4. Once you have reached the new location of the link, release the mouse button.

   The link moves as you slide the pointer.

### 5.2.2.4. Inserting a Fork

It is possible to insert a fork in an existing link by using the Link button:

1. Click on the Link button of the Insert toolbar.

   The mouse pointer takes this shape \( \uparrow \rightarrow \).

2. Click on the location of the link where you want to insert a connection port or a fork.

   A new connection port is created and a new link is being drawn.

3. Click to draw the desired shape of the link.

4. If you do not wish to connect the other end of the link, click anywhere you wish in the
   diagram. If the other end of the link is to be connected to a connection port, click once on
   the connector to terminate the link.

### 5.2.2.5. Dividing a Link

A link may be cut so as to obtain two distinct links. As well, two criss-crossing links can be
   cut into four distinct links. Dividing links allows you to cut a link at a specific location.

To divide a link:

1. Click on the Break Link button of the Layout toolbar.

   The mouse pointer assumes this shape \( \uparrow \rightarrow \).

2. Click on the location of the link where you wish to divide it.

   ![Figure 5–7: Example of a divide link](image)
The link is cut in two.
The mouse pointer reverts to its initial shape.
Each of the new links can be separately selected.

💡 If the connection ports display is activated, then a new port will be displayed between the two new links. For more detail, refer to the Connection Ports and Contact Points section.

### 5.2.2.6. Transforming Two Links into a Single Link

You can join two distinct links into a single one.

To joint two links:
1. Select the first link.
2. Select the second link while pressing the SHIFT key.
3. Click on the Joint Links button from the Layout toolbar.

The connection port disappears and the two links become a single one.

### 5.2.2.7. Modifying the Shape of a Link

Occasionally, the layout of elements on the diagram requires modifying the shape of a link to avoid overlapping.

To modify the shape of a link:
1. Select the link to modify.

The link assumes the colour of the selection.

2. Click on the location of the link where you wish to modify it and click on the left-mouse button.

In this situation, the mouse pointer takes one of these shapes.

3. Without releasing the mouse button, slide the pointer to its new location.
The link is modified as you slide the pointer.

4. Release the mouse button.

The link is modified.

The mouse pointer reverts to its initial shape.

5. Repeat steps 2 to 5 for each part of the links that needs to be modified.

To modify a link into a direct link, select the link you wish to modify and select the Direct Link option of its contextual menu.

5.2.2.8. Modifying the Link’s Properties

Each link’s properties (pressure line, pilot line, electrical wire, etc.) that are available in the software can be modified. When connected to hydraulic, pneumatic, electric, numeric, or scale diagram components, these links adopt that technology’s properties.

To do so:

1. If the link has no angle: double-click on the link but not on the connectors. If the link has one or more angles, double-click on one of the angles or select the link itself.

2. Choose Edit → Component Properties.

The Component Properties dialog box opens.

3. Modify the fields accordingly.

4. Click on the Apply button to validate the modifications.

5. Click Close to return to the diagram.
Refer to the contextual help of the link for more details on its properties. Use the Format toolbar’s button to modify the thickness and colour of a link.

### 5.2.2.9. Laying Out Components on Links

In order to increase the performance rate of a diagram, it is helpful to use the automatic insertion function of a component on an existing link. This action inserts the component by automatically cutting the link at the insertion point.

Conditions of user: This function is operational only if a single ungrouped component is moved on the link.
Case #1: Inserting a component directly from the library, from a different diagram, or by a copy.
Simply select the component and insert it on the link making sure that the connector(s) is set precisely on the link when releasing the component on the diagram.

Case #2: Moving a component on a link (both items are on the same diagram).
Simply move the component on the link while ensuring that the connector(s) remains on the link and that the SHIFT key is pressed when releasing the component.

The SHIFT key allows the user to automatically insert a component on a link or to disconnect it from a link.

5.2.3. Verifying Connections

The Verify Connections command from the Tools menu allows the user to identify which link or component has free connectors.

To verify the status of connections:
1. If connectors are hidden, display them by choosing View → Connection Ports.
2. Choose Tools → Verify Connections.

If one or more connectors in the diagram are free, the Messages window opens.

Every free connector and unlinked component is automatically selected in order to easily identify them.
5.3. **Component Properties**

5.3.1. **Introduction**

Each symbol in the main library represents a component. Each of these components has properties of different origins. The objective of this section is to define the role and use of these different types of properties.

💡 To appreciate the exact role of each property of a component, refer to its contextual help.

5.3.2. **Standards and Specifications**

Automation Studio allows the user to draw hydraulic and pneumatic diagrams based on the ISO 1219-1 Standard. As there remain some missing measurements within this standard, measurements of the 1219-1.2 Standard, which is in the process of being approved, have been selected. The displayed information is recommended by the ISO 4413 and ISO 4414 Standards.

The internal identifier of each component in hydraulic, pneumatic, and electricity technologies, is constructed based on the ISO 1219 – 2 Standards, i.e. the code is a concatenation of several component properties.

Internal code = Installation number – Circuit number.ISO component code.Automatic increment.

- The installation and circuit numbers are properties from the document, and are accessible through Edit → Document Properties → Diagram. The user can modify these fields. As soon as a component is inserted into a diagram, these two document properties are assigned to the component by default. These two component properties can easily be modified simply by opening the component’s properties dialog box to the Displayed Information branch.

- The ISO component code is defined in the following manner:
  - Pumps and compressors: P
  - Actuators: A
  - Prime mover: M
  - Sensors: S
  - Valves: V
The ISO display for the software configuration options allows the display of all of the information for each fluid component as recommended by the ISO 1219 – 2 Standard. Symbols from other technologies, such as the IEC 61131 and JIC standards are respected. The internal code of the component is constructed in the same manner as for the hydraulic and pneumatic components. This method insures the uniqueness of the component and allows the variable assignments to be based on this internal code.

5.3.3. Component Properties Dialog Box

To visualize and modify a property:

1. Click on the tree structure element to modify.

![Figure 5–11: Component Properties dialog box of a single component or group](image)

This Component Properties dialog box is usually composed of the following elements:
### Areas Description

<table>
<thead>
<tr>
<th>Areas</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>A</td>
<td>Title bar: This bar contains the name of the dialog box followed by the name of the component.</td>
</tr>
<tr>
<td>B</td>
<td>Display window: This window displays the symbol. It is very helpful when the component is modifiable. It allows visualizing any modifications applied to the symbol.</td>
</tr>
<tr>
<td>C</td>
<td>Tree structure of group: This window appears only for grouped components.</td>
</tr>
<tr>
<td>D</td>
<td>Display window of available families of properties: The information displayed in this window varies in accordance with the component. Simply click on one of the branches to display the component’s related properties in the right area of the dialog box.</td>
</tr>
<tr>
<td>E</td>
<td>Property areas: Areas displaying modifiable property fields of the selected properties branch.</td>
</tr>
<tr>
<td>F</td>
<td>More/Less: This button allows the user to display or hide the Advanced Data properties area of the component.</td>
</tr>
<tr>
<td>G</td>
<td>Apply: This button allows the user to enforce modifications on properties.</td>
</tr>
<tr>
<td>H</td>
<td>Reset: This button allows the user to cancel modifications before their validation with the Apply button.</td>
</tr>
<tr>
<td>I</td>
<td>Help: This button allows the user to launch the contextual help for this dialog box.</td>
</tr>
<tr>
<td>J</td>
<td>Close: This button allows the user to close the dialog box and returning to the actual diagram.</td>
</tr>
</tbody>
</table>

### 5.3.4. Components’ Technical Data

Physical parameters are used in the graphic or analog behaviour template of the component. Their values are evaluated and inserted in the calculation of the system’s solution composed to diagrams to simulate.

💡 Units used in this dialog box are from the system configured during the software’s installation. They can be converted automatically in the drop-down list of suggested unit types.
5.3.4.1. Basic Data
This data corresponds to the setting and/or dimensional parameters of the component. It allows the user to adjust the behaviour’s Graphic Template or Analog Template of the component. The user can modify this data.

5.3.4.2. Advanced Data
Some of this data is used as extreme values of physical parameters supported by the component and are present for information purposes only (maximum capacity, etc.). Some others are used to define abscise and ordinate intervals of characteristic curves (full pressure differential, maximum output, etc.). Some more are advanced parameters of specific components such as internal leakage, friction, etc.

5.3.4.3. Calculated Data
This data is automatically calculated based on the Basic Data and Advanced Data. The calculated data cannot be modified by the user; neither can its value nor its unit.

5.3.5. Catalog Information

⚠️ You must own the required license to access this module. Choose Help → About to find out more about your current license.

This information is related to a symbol and is used to generate different types of reports such as order forms, commercial and technical reports, etc. Refer to the help text related to Report Creation to learn how to use this information.

5.3.5.1. Part Information
This information is associated to the part and usually comes from a catalog. It is either manually or automatically entered by pressing the Find Part button. To use this button, refer to the Catalog section. It is possible to assign customized information to the component. This information is entered manually.

5.3.5.2. List of Accessories
This information allows the user to assign to a component a list of accessories that are identified by their part number, price, and quantity. This information in manually or
automatically entered by pressing the Find Part button. To use this button, refer to the Catalog section.

![Component Properties dialog box, Catalog Information branch](image)

**5.3.6. Displayed Information**

The information listed in this dialog box is displayed on the diagram while in the editing or simulation mode, but only if the checkbox next to the information is checked. The standard information is displayed and set next to the symbol; the other information is displayed in the centre of the symbol. It originates from the Technical Data, Variable Assignment, and/or Catalog Information. Refer to the Standards and Specifications section to learn more on specific standard configurations available in the software.

![Lightbulb icon]

The information that is displayed on the diagram can be modified directly on the diagram just like regular text. The modification is replicated in the component’s properties dialog box.
The information of the component displayed on the diagram is called a satellite.

Figure 5–13: Component Properties dialog box, Displayed Information branch
5.3.7. Characteristic Curves

Characteristic curves are used during the simulation for components whose templates are defined by a graphic modelling. Usually, a curve is defined for a specific value of a parameter from one entry of the Basic Technical Data.

The Characteristic Curves dialog box contains the following areas:

<table>
<thead>
<tr>
<th>Area</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>A</td>
<td>Graphic Chart Area used to visualize the selected component’s curves.</td>
</tr>
<tr>
<td>B</td>
<td>Axis of the Abscise (X-Axis) Value of abscises defined in the installation unit of the software.</td>
</tr>
<tr>
<td>C</td>
<td>Axis of Ordination (Y-Axis) Value of ordinates defined in the installation unit of the software.</td>
</tr>
<tr>
<td>D</td>
<td>Point Coordinates The values of the selected curve in points (abscise, ordinate). The header of the table contains the name of the parameter displayed</td>
</tr>
</tbody>
</table>

Figure 5–14: Component Properties dialog box, Characteristic Curves
Creating a Diagram

<table>
<thead>
<tr>
<th>Area</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>in abscise (1st column) and in ordinate (2nd column).</td>
</tr>
<tr>
<td>E</td>
<td>Curves Setting</td>
</tr>
<tr>
<td></td>
<td>Parameter considered for each curve and its modifiable value.</td>
</tr>
<tr>
<td>F</td>
<td>Constraints</td>
</tr>
<tr>
<td></td>
<td>Constraints to respect while editing the curve.</td>
</tr>
</tbody>
</table>

Most hydraulic and pneumatic components behave in a way that can be graphically portrayed. Automation Studio includes, for each component of this type, a set of standard curves reflecting the builders’ measures. For one component, each curve is associated to the same parameter whose value differs based on the selected curve. This parameter can be edited in its associated field. This parameter is also visible in the basic technical data of the component. The value of the visible parameter in the Technical Data can be modified although it does not mean that a curve will be defined for that specific value. However, the simulator automatically creates a curve based on the parameter of the component using the in-betweening method. This curve is constructed dynamically by the simulator and is not visible to the user.

To edit a curve, simply:

1. Select the curve to modify.

The selected curve changes colour.

2. Modify the value of the curve’s parameter if necessary.

If you wish, look at the value of the actual component’s parameter in the Technical Data then associate the value to the curve. Thus, the curve being edited, not the in-betweening, will be used by the simulator.

3. Modify the values of the points’ coordinates that are displayed in the chart.

4. Validate modifications using the Apply button or by selecting a different curve.

While validating, constraints are applied with regards to the increase rate of the curve.

- Strictly increasing curve;
- Strictly decreasing curve.

For the simulator, a pressure curve based on rate is strictly (de)increasing if the variation rate in absolute value is higher than 1 bar for 1000 LPM, either \( \frac{dp}{dq} > 0.1 \) bar/LPM or \( \frac{dp}{dq} > 5.5 \) psi/GPM.
These curves allow simulating real or dysfunctional behaviours.

5.3.8. Component Configurator

The existing builders are those related to:

- Pneumatic and hydraulic distribution valves;
- Pneumatic and hydraulic cylinders;
- Pneumatic sequencers.

To learn more on how to use the builders, refer to the contextual help of the component.

5.3.9. Variable Assignment

Automation Studio uses components’ variables and internal variables not linked to components.

Components’ variables are automatically created when they are inserted in the diagrams. Logical internal variables must be created by the user in the Ladder or SFC components’ properties.

Some components act as transmitters, i.e. they are transmitting their status or value to other components or variables. As an example: a relay coil transmits its status to contacts that refer to it.

Other components act as receivers, i.e. they receive their status or value from a transmitting component or internal variable. As an example: a relay contact receives its status from the coil to which it refers.

Some components have several variables, some of which act as transmitters and others as receivers.

Internal variables can act as transmitters and as receivers.

The assignment of variables allows the user to create a Read or Write link for a specific variable to a compatible variable or to an external variable, such as an element from an OPC server. These links are used by the simulator to evaluate the status of components as well as internal and external variables during a simulation.
5.3.9.1. **Variable Assignment Branch**

Options within this dialog box differ depending on whether the component is a transmitter or a receiver.

![Diagram of Component Properties dialog box, Variable Assignment branch for transmitter and receiver components](image)

The following is a description of the fields that make up this dialog box:
## Area Description

<table>
<thead>
<tr>
<th><strong>A</strong></th>
<th>Table of the component’s variable properties</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Tag name: The internal variables’ tag names can be modified. These variables are transmitters as well as receivers. They can have a Read/Write external link. It is impossible to directly define an internal link for internal variables. However, it is possible to create a Write link between a transmitter variable of a component and an internal variable. It is also possible to create a Read link between a receiver variable of a component and an internal variable.</td>
</tr>
<tr>
<td></td>
<td>• Unless defined otherwise, transmitter variables do not have a default tag name. The user can modify the tag name.</td>
</tr>
<tr>
<td></td>
<td>• Unless defined otherwise, receiver variables have the “?” character defined as their default tag name. The variable takes the component’s tag name to which it is Read linked as an internal or external link. This tag name cannot be modified by the user.</td>
</tr>
<tr>
<td></td>
<td>Address: The address of the variable for the API variables.</td>
</tr>
<tr>
<td></td>
<td>Internal ID: The component’s identifier to which the variable belongs. This identifier is generated by the application and is not modifiable.</td>
</tr>
<tr>
<td></td>
<td>R/W: This field indicates if the variable is a Read or Write link. The variable to which it is linked is selected in the Compatible Variables list.</td>
</tr>
<tr>
<td></td>
<td>Type: Displays the type of the variable, either Boolean, Integer (32 bits), or Float (32 bits).</td>
</tr>
<tr>
<td></td>
<td>Document: Displays the source of the component or variable. For a component, it refers to the diagram where it appears. For a global internal variable, it refers to the active document. For a local internal variable, it refers to the diagram or SFC document to which it belongs.</td>
</tr>
<tr>
<td></td>
<td>Description: Comment related to the variable.</td>
</tr>
<tr>
<td></td>
<td>Value: Initial value of the variable.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th><strong>B</strong></th>
<th>Modify</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Allows modifying the selected component’s variable properties. See the Modifying a Variable section.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th><strong>C</strong></th>
<th>Delete All Links</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Allows removing all the links to the selected variable.</td>
</tr>
</tbody>
</table>
Area | Description
--- | ---
D | Link Allows the user to create a link between the component’s variable and its compatible variable.
E | Read/Write Allows the user to select of the type of link. If the selected component is a transmitter/receiver, the user can select if the link is either Read or Write. Compatible variables are displayed based on the selection. If a link exists, the compatible variable to which the link is attached is selected.
F | Compatible Variable List When this type of link is selected, a table containing the Compatible Variable list from which Read/Write links are created is updated.
G | OPC Link The button calls up the OPC Settings dialog box for the creation of links on OPC items from an API or other sources. See the Creating an External Link section.

### 5.3.9.2. Creating an Internal Link

To create an internal link:

1. Select a variable from the table of properties of the variable.
2. Select the type of link if required based on the context (Read/Write).
3. Select a variable from the table of compatible variables.
4. Click the Link button.

Click on the Delete All Links to remove all internal and external links of the selected variable.

5. Click on the Apply button.

The Read Link column or Write Link column is updated depending on the context.

6. Click the Close button to return to the diagram.

The diagram is updated.

### 5.3.9.3. Creating an External Link

To create an external link:

1. Select a variable from the table of properties of the variable.
2. Click on the OPC Link button.

The OPC Settings for the creation of external links opens based on the selected technology. See Figure 5–16: OPC Settings dialog box, Link tab.

If your license does not include the communication option, these options are greyed out. Choose Help → About to find out more about your license.

3. Click on the Server tab to open the dialog box designed for OPC servers. See Figure 5–17: OPC Settings dialog box, Server tab.

4. Click on the New button to open the Add Server dialog box. See Figure 5–18: Add Server dialog box.

5. Select a server and click OK to validate your selection and close the dialog box. The OPC Settings – Servers dialog box is updated.

Be careful, the selected server must be available.

6. Click on the Groups tab to display the OPC Items groups. See Figure 5–19: OPC Settings dialog box, Group tab.

7. Click on the New button to open the Add Group dialog box for the creation of a new OPC item group. See Figure 5–20: Add Group dialog box.

8. Fill in the fields of the dialog box and click on the OK button to validate the information and return to the OPC Setting – Groups dialog box.

The OPC Setting – Groups dialog box is updated.

9. Click on the Link tab to open the OPC Setting – Link dialog box for the creation of links on OPC items. See Figure 5–21: OPC Settings dialog box, Link tab – Links created.

10. Select a server and a group, then specify if the link must be Read or Write.

11. Click on the variable you want.

12. Click on the OPC item.

13. Click on the Link button.

The link is created and appears in the list of links. See Figure 5–21: OPC Settings dialog box, Link tab – Links created.
To link several variables, check the Direct Link checkbox, click on a variable, then click on the OPC item. Repeat for each new link. Created links are displayed in the Link list.

14. Click OK to terminate and validate the creation of new external links.

15. Click on the Apply button of the component’s properties dialog box.

The columns of the table of properties of the variable are updated based on the context. See Figure 5–22: Component Properties dialog box after the creation of OPC links.

16. Close the Component Properties dialog box by pressing the Close button. The diagram is updated. See Figure 5–23: Receiver component after the creation of a Read external link.

The link is updated in the properties of the variable. Based on the context, the “R”, “W”, or “R/W” indicator appears in the R/W column of the table of properties of the variable.

If it is a Write external link for a receiver component’s variable, the variable take the name of the OPC item. If it is a Read or Write external link for a transmitter component’s variable or internal variable, the variable keeps its name.
The following describes the various tabs that make up this dialog box:

<table>
<thead>
<tr>
<th>Tab</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>A Server</td>
<td>Grants access to the OPC Servers dialog box.</td>
</tr>
<tr>
<td>B Group</td>
<td>Grants access to the OPC Groups dialog box.</td>
</tr>
<tr>
<td>C Link</td>
<td>Grants access to the Link dialog box.</td>
</tr>
</tbody>
</table>
The following is a description of the items that make up this dialog box:

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>A</td>
<td>Server</td>
</tr>
<tr>
<td>B</td>
<td>State</td>
</tr>
<tr>
<td>C</td>
<td>Group</td>
</tr>
<tr>
<td>D</td>
<td>Info</td>
</tr>
<tr>
<td>E</td>
<td>OPC</td>
</tr>
<tr>
<td>F</td>
<td>Start Time</td>
</tr>
<tr>
<td>G</td>
<td>New</td>
</tr>
<tr>
<td>H</td>
<td>Delete</td>
</tr>
</tbody>
</table>

A **Server** List of active servers.

B **State** Status of servers.

C **Group** Number of groups of OPC items per server.

D **Info** Information on the server.

E **OPC** Version of the OPC standard supported by the server.

F **Start Time** Time and date of the most recent server start-up.

G **New** This button allows access to the server selection dialog box.

H **Delete** This button allows the user to remove the selected server from the list.
<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>I</td>
<td>Connect</td>
</tr>
<tr>
<td>J</td>
<td>Disconnect</td>
</tr>
</tbody>
</table>

![Add Server dialog box](image)

*Figure 5–18: Add Server dialog box*

The following is a description of the items that make up this dialog box:

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>A</td>
<td>Registered OPC Servers</td>
</tr>
<tr>
<td>B</td>
<td>Server Types</td>
</tr>
<tr>
<td>C</td>
<td>Start Server</td>
</tr>
<tr>
<td>D</td>
<td>Server Messages</td>
</tr>
</tbody>
</table>
Figure 5–19: OPC Settings dialog box, Group tab

The following is a description of the items that make up this dialog box:

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>A</td>
<td>Group</td>
</tr>
<tr>
<td>B</td>
<td>Active</td>
</tr>
<tr>
<td>C</td>
<td>Cnx</td>
</tr>
<tr>
<td>D</td>
<td>Server</td>
</tr>
<tr>
<td>E</td>
<td>Item</td>
</tr>
<tr>
<td>F</td>
<td>Update Rate</td>
</tr>
<tr>
<td>Item</td>
<td>Description</td>
</tr>
<tr>
<td>------</td>
<td>-------------</td>
</tr>
<tr>
<td>G</td>
<td>Deadband</td>
</tr>
<tr>
<td></td>
<td>Gap required in order for the OPC client to conclude a value modification for integer and float items. The number in parentheses is the value adjusted to the server’s value.</td>
</tr>
<tr>
<td>H</td>
<td>Comment</td>
</tr>
<tr>
<td></td>
<td>Comments about the group.</td>
</tr>
<tr>
<td>I</td>
<td>New</td>
</tr>
<tr>
<td></td>
<td>This button allows access to the Add Group dialog box.</td>
</tr>
<tr>
<td>J</td>
<td>Modify</td>
</tr>
<tr>
<td></td>
<td>This button allows access to the Modify Group dialog box for the selected group.</td>
</tr>
<tr>
<td>K</td>
<td>Delete</td>
</tr>
<tr>
<td></td>
<td>This button allows the user to remove the selected group from the list.</td>
</tr>
<tr>
<td>L</td>
<td>Enable</td>
</tr>
<tr>
<td></td>
<td>This button allows the user to activate the selected group.</td>
</tr>
<tr>
<td>M</td>
<td>Disable</td>
</tr>
<tr>
<td></td>
<td>This button allows the user to deactivate the selected group.</td>
</tr>
</tbody>
</table>

![Add Group dialog box](image)

*Figure 5–20: Add Group dialog box*
The following is a description of the fields that make up this dialog box:

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>A Server</td>
<td>This dropdown list allows the user to select the server that will contain the group. It is impossible to modify the selection of the server when modifying the group’s properties.</td>
</tr>
<tr>
<td>B Group</td>
<td>This field allows the user to enter the name of the group. It is possible to change this name when modifying the group’s properties.</td>
</tr>
<tr>
<td>C Update Rate</td>
<td>This field allows the user to specify the interval to which the value of the group’s items will be updated. It is possible to modify the update rate when modifying the group’s properties. The server attempts to respect the requested update rate. The actual update rate and the requested update rate are displayed.</td>
</tr>
<tr>
<td>D Deadband</td>
<td>This field allows the user to enter the variation percentage to conclude in a Boolean or float value modification.</td>
</tr>
<tr>
<td>E Comments</td>
<td>This field allows the user to enter a comment for the group.</td>
</tr>
<tr>
<td>F Activate Group</td>
<td>This checkbox allows the user to activate the group when connecting to the server. The group must be active in order to create links to OPC items.</td>
</tr>
</tbody>
</table>
The following is a description of the items that make up this dialog box:

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>A</td>
<td><strong>Automation Studio Tags</strong>&lt;br&gt;This list allows the user to select an Automation Studio variable in order to link it in either Write or Read mode to an OPC item. The access path of the selected variable is displayed at the bottom of the list. A variable that is already linked cannot be linked a second time. The \textsuperscript{W} icon indicates that the variable is Write linked and the \textsuperscript{R} icon indicates that the variable is Read linked.</td>
</tr>
</tbody>
</table>
### Item Description

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>B</strong> OPC Items</td>
<td>This tree-structured list allows the user to select an OPC item to Write or Read link it to an Automation Studio variable. The access path to the selected item is displayed at the bottom of the list.</td>
</tr>
<tr>
<td><strong>C</strong> Link</td>
<td>The Link button <img src="image" alt="Link button icon" /> allows Write or Read linking an Automation Studio variable to an OPC item.</td>
</tr>
<tr>
<td><strong>D</strong> Direct Link</td>
<td>This checkbox allows the user to successively link several variables to each other without having to click the Link button every time. When this checkbox is checked, simply select a variable and an OPC item, the link will be automatically generated.</td>
</tr>
<tr>
<td><strong>E</strong> Project</td>
<td>This area displays the name of the current project.</td>
</tr>
<tr>
<td><strong>F</strong> OPC Configuration</td>
<td>This field allows selecting an active server and group. It also allows specifying whether the link is Read or Write.</td>
</tr>
<tr>
<td><strong>G</strong> List of links</td>
<td>The list of links is displayed at the bottom of the dialog box. The value of OPC items is updated based on the requested update rate. An NA value indicates that the item cannot be updated either because the server cannot communicate with the target or because the item is not configured in the server.</td>
</tr>
</tbody>
</table>
5.4. Detailed Information on the Component

Consult the on-line help of each component by selecting the Context Help option from the pop-up menu of the component.

5.5. Modifying a Diagram

5.5.1. Element Selection

5.5.1.1. Selecting an Element

The selection of an element is executed simply by clicking on the desired element.
To select a graphic object, you must click specifically on one of the handles of the object. For more information, refer to the Inserting a Graphic Element section. You can also use the selection by using the framing method.

### 5.5.1.2. Selecting Several Elements

You can select several non-consecutive elements by holding the **SHIFT** key down when selecting elements.

### 5.5.1.3. Selecting by Framing

The framing method allows selecting several consecutive elements quickly.

To select several elements by framing:

1. Imagine a frame surrounding the elements to select.
2. Position the pointer at one of its corners.
3. Click and drag toward the opposite corner.

A frame is drawn as you slide the pointer.

4. Adjust the frame to include every element.

Only elements that are completely framed will be selected.

5. Release the mouse button.

Selected elements will assume the selection colour.

---

*Figure 5–24: Creation of a frame for a multiple elements selection*
5.5.1.4. Selecting All the Elements

To select every element in your diagram:
1. Choose Edit → Select All (CTRL + A).

5.5.2. Relocating Elements

This procedure applies to every element. By following every step of this procedure, you will relocate a component, a link, or an object.

To relocate an element:
1. Select the element you wish to relocate.
   The component assumes the selection colour.
2. Click on the element and without releasing the mouse button, slide the pointer to the new location of the element.
   The element follows the mouse pointer.
3. Once you have reached the new location of the element, release the mouse button.

   If you select several elements simultaneously, a frame appears next to the pointer representing the selection while relocating.

   If you relocate a linked component, the links will remain active. To disconnect them, press the SHIFT button when sliding the pointer.

5.5.3. Duplicating Elements

You can duplicate an element in order to obtain an exact copy of it on your diagram.

The Duplicate command does not use the Clipboard function of Windows. It allows you to execute the duplication of elements while leaving the contents of the Clipboard intact.

To duplicate an element:
1. Select the element to duplicate.
2. Choose Edit → Duplicate (CTRL + D).
3. Move the pointer to the location where you want the duplicate to appear at and click. A copy of your selection is inserted in your diagram.

You can duplicate an element simply by holding the CTRL key down while executing a click and drag on the selected element. The copy of the element follows the pointer to the new location or until you release the mouse button.

5.5.4. Deleting Elements

To delete an element (component or selection):
1. Select the element you wish to remove from the diagram.
2. Choose Edit → Delete (DEL).

The selection is removed from the diagram.

5.5.5. Modifying Elements

5.5.5.1. Element Orientation

When creating a diagram, you can modify the orientation of element in order to allow you to organize the graphic representation of the circuit.

To modify the orientation of an element:
1. Select the object to reorient.
2. Choose the Layout menu option that corresponds to the direction in which you wish the element to face. Refer to the Layout Menu section for a description of these commands.

5.5.5.2. Display Order

Just like sheets of paper on a desk, the objects drawn first find themselves underneath the ones drawn more recently. It is, however, possible to modify this display order.

To modify the display order of a graphic object:
1. Select the object to modify.
2. Choose Layout → Bring to Front, Send to Back, Bring Forward, and Send Backward, all of which allow you to modify the display order as you wish.
The display order of elements is modified.

### 5.5.5.3. Grouping Elements

It is possible to group several elements such as components, graphic objects, etc. in order for them to behave as a single element. Afterwards, they may be relocated simultaneously simply by selecting the group.

To group elements:
1. Select the elements you wish to group.
2. Choose Layout → Group (CTRL + G)

Elements are now in a single group.

### 5.5.5.4. Ungrouping Elements

To ungroup elements:
1. Select the group
2. Choose Layout → Ungroup (CTRL + U)

Elements are now ungrouped.

### 5.5.6. Transferring Elements Between Diagrams

The Clipboard is a functionality from Windows that allows the temporary stocking of data for an information transfer.

You can use this function to transfer or copy elements from one diagram to another.

#### 5.5.6.1. Transferring or Copying a Selection

To transfer a selection or its copy in another diagram:
1. Select the element you wish to transfer.
2. Depending on whether you wish to transfer or copy the selection, choose either the Cut or Copy function from the Edit menu.

Based on your previous choice, the selection is removed or copied from your diagram and stocked in the Clipboard.
3. Open the diagram on which you wish to transfer or copy the selection.

The second diagram appears on the screen.

4. Choose Edit → Paste (CTRL + V)

The copied or transferred element appears next to the pointer.

If you have selected several elements simultaneously, a frame linked to the pointer represents the selection during the relocating.

5. Move the pointer and click at the new location where you wish to insert the content of the Clipboard.

The contents of the Clipboard are inserted on the diagram.

If you wish to copy a selection, simply drag it onto the same diagram or onto a different diagram and make sure you press the CTRL key when releasing the mouse button.

**5.5.6.2. Transferring a Diagram into Another Diagram**

The transfer procedure of a diagram is identical to the transfer procedure of an element, consult the previous section. Simply choose the Select All command from the Edit menu to execute the selection before transferring or copying the element to another diagram.

**5.5.7. Properties of a Component or Selection**

Open the Component Properties dialog box of the component.

To edit, modify the component or selection properties:

1. Choose Edit → Component Properties (ALT + ENTER).

**5.5.8. Connection Ports and Contact Points**

There are two types of connections: connection ports and contact points. Connection ports join two components and allow the transmission of fluids such as air or oil, or electricity. Contact points join a transducer and a receiver allowing a component to influence another’s behaviour.
Connections are represented by a circle that appears at the point of connection. The colour of the circle indicates the connection status (linked or free).

Mechanical contacts are represented by a diamond that appears at the contact point. Contrary to connections, the colour of diamonds is not influenced by the connection status.

When you overlap two connections, they change colour to indicate that the link has been established. In this way, you can quickly identify free connectors.

To display or hide connectors:

1. Choose View → Connection Ports or Contact Points.

Connection ports or contact points appear on the screen when these commands are checked.

**5.5.9. Connection Ports Name**

The display of connection ports’ names is a helpful function when the time comes to create a real set-up based on a diagram. At that time, this information helps to quickly and easily define what connections need to be made.

To display or hide the connection ports’ names:

1. Choose View → Connection Ports Names.

The connections’ numbers appear or disappear from the screen.

To print the connection ports’ names:

2. Display the connections’ numbers before launching the printout.

(For more details on launching a printout, refer to the Print section).
5.5.10. Component Snap

When selected, this function allows relocating elements on a diagram based on the grid precision.

To select or deselect the rulers’ display:

1. Choose View → Component Snap.

5.5.11. Grid Properties

When selected, this function allows transforming (homothety) elements on a diagram based on the grid precision.

To select or deselect the grid’s display:

1. Choose View → Grid.

The grid’s properties allow the user to define the level of precision for the snap of graphic elements into a diagram. This precision is helpful when creating a diagram requiring a finer execution.

The grid colour can be modified in the Grid Properties dialog box.

Graphic objects, such as line, circles, etc., snap by default to the grid in the same manner as components do. However, it is possible to specify a finer proximity snap, but only for graphic objects only.

To modify the grid:

2. Choose View → Grid Properties.

The Grid Properties dialog box appears on the screen.

3. Choose the grid’s display colour.
4. Choose the graphic snap precision.
5. Click OK.

Choosing ¼ for example, will allow the graphic objects to be four times more precise in its location than what the grid displays.
5.6. Inserting a Graphic Element

Layout procedures of graphic elements available in the Insert menu are similar. So, lines, rectangles, and ellipses are inserted in the same manner, while text boxes, pictures, and fields differ in the last few steps of the insertion procedure. Links, arcs, and polygons use a distinct procedure.

5.6.1. Inserting a Line, a Rectangle, and an Ellipse

In order to avoid redundancy in the text, only one graphic object’s procedure will be described since it is sensibly the same.

To insert an ellipse:

1. Choose Insert → Ellipse.

   The pointer assumes the shape of the selected object.

2. Click on the left-mouse button without releasing it and drag the pointer in the opposite direction.

   While dragging, the shape of the object appears and changes due to the mouse movements.

3. Release the mouse button when the object has reached the desired dimensions.

   The graphic object is displayed on the diagram.
4. Repeat steps 2 and 3 for every graphic object you wish to insert in the diagram. It is not necessary to repeatedly select the tool when several of the same object have to be drawn.

5. To stop inserting graphic objects, simply click on the right-mouse button. The pointer reverts to its original shape.

Contrary to technology related links, a line does not transmit signals during the simulation. Hence, it cannot be used to join elements.

5.6.2. Inserting a Text Box, a Picture, and a Field

In order to avoid redundancy in the text, this procedure starts when releasing the mouse button.

To insert a text box:
1. Repeat steps 1 through 3 of the previous procedure making sure you select the Text tool.
2. In the Text area, type in the text to include in the diagram.
3. To stop inserting graphic objects, simply click on the right-mouse button. The pointer reverts to its original shape.

To insert a picture:
1. Repeat steps 1 through 3 of the previous procedure making sure you select the Picture tool.

The Insert Picture dialog box opens.
2. Select the picture you wish to insert in the diagram.
3. Click on Open.

The picture appears in the diagram.
4. To stop inserting graphic objects, simply click on the right-mouse button. The pointer reverts to its original shape.

The chosen picture may be inserted in a diagram in order to illustrate the behaviour of a circuit or to customize a cartridge.

To insert a field:
A field is a text zone that cannot be modified and may contain:

- A property of the current project, such as the author, creation date, etc.
- A property of the current document, such as the author, creation date, etc.

1. Repeat steps 1 through 3 of the previous procedure making sure you select the Field tool.

The Component Properties dialog box opens.

2. Select the category and the name of the field you wish to see in the diagram.

3. Click on Apply to validate the selection.

4. Click on the Close button to confirm and return to the diagram.

The field value appears in the diagram.

5. To stop inserting graphic objects, simply click on the right-mouse button.

The pointer reverts to its original shape.

You must fill in the active project’s and/or the diagram’s properties in order for the selected fields to show a value.

### 5.6.3. Inserting a Link, an Arc, and a Polygon

In order to avoid redundancy in the text, the procedure starts when releasing the mouse button.

To insert a link:

1. Repeat steps 1 through 3 of the previous procedure making sure you select the Link tool.

2. Click a second time to anchor the end-point of the link in the diagram, therefore creating a directional change for the link.

3. To stop inserting graphic objects, simply click on the right-mouse button.

To lengthen the link:

4. Continue clicking as long as necessary.

5. To stop inserting graphic objects, simply click on the right-mouse button.

The pointer reverts to its original shape.

Each click executed after the original click and drag corresponds to a change of direction of the link for as long as the tool has not been unselected.

5-48
To insert an arc:
1. Repeat steps 1 through 3 of the previous procedure making sure you select the Arc tool. The initial shape of the arc corresponds to ¾ of a circle. To create the arc:
2. Click on one of the handles (one is at 9 o’clock and the other is at 12 o’clock) and without releasing the mouse button, drag the pointer to either lengthen or shorten the arc based on your needs.
3. To stop inserting graphic objects, simply click on the right-mouse button. The pointer reverts to its original shape.

To insert a polygon:
1. Repeat steps 1 through 3 of the previous procedure making sure you select the Polygon tool. As soon as the mouse button is released, the second anchor point is created:
2. Change direction and click a second time to fasten the third anchor point of the polygon in the diagram.
3. Repeat the previous step as often as necessary.
To close the polygon:
4. While still using the Polygon tool, click on the start anchor point of the polygon.
5. To stop inserting graphic objects, simply click on the right-mouse button. The pointer reverts to its original shape.

5.6.4. Attributes of Graphic Objects
You can modify some attributes of graphic objects such as the type, thickness, colour, fill, and line start and end points. These attributes are not available for texts.

To modify attributes for graphic objects:
1. Select an object.
2. Click on the right-mouse button.
3. Choose the Component Properties command from the object’s pop-up menu.

The Component Properties dialog box opens:
Here is a description of the available fields in the graphic object’s Component Properties dialog box:

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Colour</td>
<td>Line colour for the object.</td>
</tr>
<tr>
<td>Style</td>
<td>Line style: dotted, etc. Not available for the arc.</td>
</tr>
<tr>
<td>Thickness</td>
<td>Thickness of the line</td>
</tr>
<tr>
<td>Pattern</td>
<td>Fill pattern. Not available for the line.</td>
</tr>
<tr>
<td>Foreground</td>
<td>Colour of the pattern. Not available for the line.</td>
</tr>
<tr>
<td>Background</td>
<td>Background colour of the pattern. Not available for the line.</td>
</tr>
<tr>
<td>Begin</td>
<td>Choices available for the line start. Not available for the rectangle and ellipse.</td>
</tr>
<tr>
<td>End</td>
<td>Choices available for the line end. Not available for the rectangle and ellipse.</td>
</tr>
<tr>
<td>Size</td>
<td>Size of the beginning and ending shapes of the line. Not available for the rectangle and ellipse.</td>
</tr>
</tbody>
</table>

4. Choose the necessary attributes.
5. Click Apply to validate.
6. Click OK to return to the diagram.
The selected attributes are on the object.

### 5.6.5. Plotter

When configured in Editing mode, the Plotter allows the user to obtain the drawing of variation curves of specific parameters, or of variables of a specific circuit or component while in the Simulation mode.

1. Choose Window → Display → Plotter.

The Plotter window opens:

![Plotter window](image)

*Figure 5–29: Plotter window*

Refer to the Plotter section for more details on how to use it.
5.6.6. Bill of Materials (BOM)

A bill of materials can be automatically inserted in a diagram. It lists the components grouped by name and informs of their quantity.

2. Click where you want the first handle of the BOM to be inserted and without releasing the mouse button, drag the pointer in the opposite direction.

   The handles define the display area of the BOM.
3. Release the mouse button to terminate the insertion.

   The BOM contains the list of components actually in the diagram.

   A group of components will be considered as a single unit if the Assembly checkbox is checked in the group dialog box.

5.7. Simulation

The simulation is the goal of a project or a diagram. It allows, among other things, to test, verify, view, and troubleshoot the modelization with diagrams.

This section covers the following topics:

- Description of the Simulation mode:
  - Selecting the current project;
  - Selecting the current diagram;
  - Selecting several items;
  - Selecting simulation items;

- Simulation speeds:
  - Normal Simulation;
  - Step by Step Simulation;
  - Slow Motion Simulation;
  - Pausing the simulation;
  - Stopping the simulation.
This section of the User’s Guide gives an overview of simulations. In the different workshops’ User’s Guides, you will find an example of simulation related to the workshop’s technology.

### 5.7.1. Description of the Simulation Mode

This section describes the overall aspects of the user interface that change when you launch a simulation. The following topics are covered:

- Menus and commands;
- Status bar;
- Display colours;
- Windows layout.

In the Simulation mode, none of the Edit commands can be used and modifications cannot be executed to the project or diagram. As a result, deactivated menus and commands are greyed out. On the other hand, you can browse through and display projects and diagrams while in Simulation mode.

⚠️ While in the Simulation mode, you can print a diagram.

The simulation of a project or diagram is launched from the Simulation menu or toolbar.

⚠️ To display the Simulation toolbar, choose Window → Display → Toolbars → Simulation.

#### Status Bar

The status bar indicates that the operating mode is the Simulation mode and shows the time elapsed during the simulation.

#### Mouse Pointer

The hand 🧵 represents the possibility of intervening during a simulation. Based on the workshop and components inserted in the diagram, you can execute different modifications such as adjusting the orifice size of the throttle in the Pneumatic workshop or activating the push-button of an on-off switch in the Electric workshop.
Display Colours

While in the Simulation mode, specific elements will assume different colours to indicate or emphasize their behaviour or simply to identify them. The use of colours allows the identification of the status change of components or links.

To learn more about the display colours in simulation, refer to the workshop’s User’s Guide.

Window Layout

When a project contains a circuit that spans several diagrams, it is helpful to layout the windows in order to have an overall view of the diagram.

1. Choose Window → Vertical Tile.
   All the windows are displayed vertically.
2. Select a diagram by clicking on its window.
3. Click on the Zoom Page button to view the entire diagram in the window.
4. Repeat the operation for every diagram.
5. Use each window’s scroll bar to centre the diagram within the window.

When you save this project containing this layout, it remains the same the next time it’s opened.

5.7.1.1. Launching the Simulation of the Project

To simulate the current project:

1. Choose Simulation → Project.
2. Choose a simulation speed from the Simulation menu.

The Simulation mode is launched.

Elements from the current project’s circuits assume the display colours related to the Simulation mode. For more details on simulation colours, refer to the software’s configuration options of the related workshop.

3. While in Simulation mode, you can open different diagrams with the Open command or create a new view with the New View command from the pop-up menu of the Project Explorer.

Opened windows containing the diagrams allow you to observe the animation of components.
The Simulation mode is indicated in the status bar.

5.7.1.2. Launching the Simulation of the Diagram

To execute the simulation of a diagram, you can simulate it alone, independently from other diagrams in the project.

To simulate a single diagram:

1. Open the diagram you wish to simulate.
   The diagram window opens and becomes active.
3. Choose a simulation speed from the Simulation menu.
   The Simulation mode is launched and applies only to the selected diagram.

The Simulation mode is indicated in the status bar.

5.7.1.3. Selecting Several Diagrams to Simulate

You can select several diagrams to simulate simultaneously. To do so:

   The Select Items to Simulate dialog box opens.
2. Click the checkboxes of the diagrams you wish to simulate.
3. Click OK.
5. Choose a simulation speed from the Simulation menu.
   The Simulation mode is launched and applies only to the selected diagram.
   The Simulation mode is indicated in the status bar.

5.7.2. Simulation Speeds

The selection of simulation speeds allows you to adapt the progress of the simulation based on your requirements. Three simulation speeds are available in the Simulation menu.
5.7.2.1. Normal Simulation

This option controls the minimal delay between each calculation cycle of the simulation when in Normal Simulation mode as opposed to the Step by Step and Slow Motion speeds.

1. Choose Simulation ➔ Normal.

The simulation is launched in Normal mode, i.e. the fastest mode.

At any time, you can increase or decrease simulation speed while in Simulation mode.

5.7.2.2. Step by Step Simulation

Simulates one cycle at every click.

To simulate in the Step by Step mode:

1. Choose Simulation ➔ Step by Step.

The simulation is launched in Step by Step mode. Each step corresponds to a click of the mouse.

At any time, you can increase or decrease simulation speed while in Simulation mode.

5.7.2.3. Slow Motion Simulation

Simulates at the slowest speed.

To simulate in the Slow Motion mode:

1. Choose Simulation ➔ Slow Motion.

The simulation is launched in Slow Motion mode.

At any time, you can increase or decrease simulation speed while in Simulation mode.
5.7.2.4. **Pausing the Simulation**

To temporarily interrupt a simulation and continue it later:

1. Choose Simulation → Pause.

The simulation is paused and can be restarted at any time.

5.7.2.5. **Stopping the Simulation**

To end a simulation and return to the Edit mode:

1. Choose Simulation → Stop.

The simulation is stopped.

The status bar indicates that the software has returned to the Edit mode.

5.8. **Verify Connections**

The Verify Connections command from the Tools menu allows you to locate links or components that are not connected.

To verify the status of the connections in your diagram.

If the connections are hidden:

1. Choose View → Connections to display them.

   A red circle appears at each connection port.

2. Choose Tools → Verify Connections.

   When a non-connected port is detected, the Messages dialog box appears.

   All the free connections are displayed and the non-connected components are automatically selected.
5.8.1. Detecting Errors in Simulation

Specific error messages may appear during the launch or execution of a simulation.

5.8.1.1. Detecting Errors in Diagrams at Launch of Simulation

The fluid simulator cannot execute its task if a connection is missing. Therefore, an error message appears as soon as the simulation is launched.

The simulator of Command technologies allows free connectors.

5.8.1.2. Detecting Communication Errors (OPC)

The status of communications is indicated in the dialog box related to the creation of links on OPC items. See Figure 5–18: Add Server dialog box.

Moreover, if the display option of messages from the server is selected in the Add Server dialog box, these messages will be displayed during the simulation. See Figure 5–17: OPC Settings dialog box, Server tab, Figure 5–19: OPC Settings dialog box, Group tab and Figure 5–21: OPC Settings dialog box, Link tab – Links created.
6. Plotter

6.1. Accessing the Plotter

To display the Plotter:

1. Choose Window → Display → Plotter or click on the Plotter button of the Simulation toolbar.

The Plotter window appears on the screen. It functions in the same manner as all the other windows, such as the Library Explorer or the Project Explorer.

*Figure 6–1: Plotter in the interface*
6.2. **Using the Plotter**

To add a curve in edit mode:

1. Open the Plotter

2. Drag and drop the selected component from the drawing surface to the Plotter window.

The Plots Selection window appears.

![Plots Selection dialog box](image)

*Figure 6–2: Plots Selection dialog box*

- If the component has no variable that can be plotted, a message saying “No available plots for this component” will appear on the screen.

3. Check the variables to be plotted (maximum of 5).

4. Click on OK to confirm the selection.

- A maximum of 5 curves can be plotted simultaneously.

Variables appear in the list as per the order defined in the Plots Selection window.

The following properties are automatically assigned by the Plotter to each curve:

- Scale: Maximum and minimum values of the plot.
• Plot Colour: Colour attributed by default to the variable during selection. It is used to identify the curve in the plotter.

• Plot Unit: Depending on the unit system determined upon installation (metric or imperial).

• Time scale: Time span visible in the plotter window.

Once the variable is configured, the next simulation will automatically start the plotting of its evolution curve.

6.3. **Plotting the Curve**

The plotting of each curve is done at each simulator cycle. Thus, the plotting will be done simultaneously with the simulation. If the simulation duration exceeds the visible plotter frame, the plotting surface will scroll to show the new time frame and a scroll bar is activated at the bottom of the window. This scroll bar will permit the user to see the entire curve once the simulation is stopped.

6.3.1. **Preserving Visual Data**

Once the simulation is stopped, the graphic data will stay on the Plotter surface. The surface will be reinitialized when the simulation is restarted.

6.3.2. **Preserving Textual Data**

After the plotting of one or more curves, it is possible to export the plot data as a tabulated *.txt file. To do so, click on the Export button in the Plotter window.

The Save File dialog box appears and opens in the root directory of the project if it has been saved once or in the Automation Studio folder if it has not yet been saved. A file is exported for each plot. The data in tabulated format can be imported into any spreadsheet application.

6.3.3. **Modifying the Colour of the Plot**

To change the colour associated to a variable:

1. Click on the button situated on the right side of the colour.

   The Colour dialog box appears.
2. Select the desired colour.
3. Click on OK to confirm the selection.
The Colours dialog box closes.
4. Click on the Apply button of the Plotter to validate the changes made to the plot.
The colour is updated in the list, on the plot, and on the scale.

6.3.4. Modifying the Plot Scale of a Variable
To modify the plot scale of a variable:
1. Click on the corresponding value in the plotter window.
2. Change the value. Make sure that the scale minimum value is inferior to the scale maximum value.
3. Click on the Apply button of the Plotter to confirm and apply changes to the drawing scale.
Plot scale is updated in the list and in the plot window.
6.3.5. Deleting a Curve

To delete a variable and its associated plot:

1. Click on the variable or on one of its values to select it.
2. Click on the Delete button.
3. Click on the Apply button to confirm the deletion and to eliminate it in the plot.

Or

4. Drag and drop the same component on the Plotter surface.

The Plots Selection dialog appears.

5. Uncheck the corresponding variables.
6. Click on OK to confirm.

© When a component is deleted from a diagram, the associated curves in the Plotter are automatically deleted. Variables can only be deleted one at a time.

6.4. Variables That Can Be Plotted

While most components from the pneumatic and hydraulic workshops offer the possibility of plotting flow and pressure, components from other workshops will offer the possibility of plotting logical state. In the case of a Boolean variable, the scale is automatically 0-1 (logical state) with no unit.
7. Field Configuration

7.1. Configuring Properties Fields

You must possess the required license to have access to this module. Choose Help → About to find out more about your license.

Many fields are already associated with all components by default. These fields can be used to identify or associate a component to a commercial product. It is also possible to define personalized catalog information fields or choose among the standard fields such as active document properties, diagram properties, and project properties that are provided by this software and associate them to the components.

The Field Configuration dialog box is used to manage user-defined fields for every component.

![Field Configuration dialog box](image)

*Figure 7–1: Field Configuration dialog box*
This is the description of the buttons in this dialog box.

<table>
<thead>
<tr>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add</td>
<td>Add a user-defined field.</td>
</tr>
<tr>
<td>Modify</td>
<td>Modify the selected user-defined field.</td>
</tr>
<tr>
<td>Delete</td>
<td>Delete a user-defined field.</td>
</tr>
<tr>
<td>OK</td>
<td>Close the dialog box and apply all changes (Add, Modify, Delete).</td>
</tr>
<tr>
<td>Cancel</td>
<td>Close the dialog box and cancel all operations (Add, Modify, Delete).</td>
</tr>
</tbody>
</table>

### 7.1.1. Adding User-Defined Fields

To create user-defined fields, starting in the Fields Configuration dialog box:

1. Click on the Add button.

   The following dialog box appears:

   ![](Figure 7–2: Add field dialog box)

2. Enter the new field name in Field Name.
3. Select the field type in the Type zone.

   Choices are:

<table>
<thead>
<tr>
<th>Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Integer</td>
<td>Can be a whole number with no decimals that ranges from –32768 to 32767.</td>
</tr>
<tr>
<td>Real</td>
<td>Can be any number between –999 999 999.99 and 999 999 999.99</td>
</tr>
</tbody>
</table>
**Type** | **Description**  
--- | ---  
Text  | Can be any type of string of up to 512 characters (letters and numbers).  
Date  | Can be any date value, as the date format is not validated.  
Currency  | Can be any price value under $999,999,999.99.  
Percentage  | Can be any two-digit percentage value.  

4. In the Value field, enter a value that will appear in every Catalog Properties dialog box of every component with which this field will be associated.  
5. Click on the OK button to validate and apply the choices made and return to the previous dialog box. Click on Cancel to cancel the changes.  
The new properties are now in the properties dialog box.  
6. Repeat steps 1 through 5 to add another user-defined field.  

User-defined fields are only available for the current project. If these fields are to be used for other projects, a template must be created. With the use of the template, these fields will be available with any future project.  

### 7.1.2. Modifying a User-Defined Field  
To modify a user-defined field, from the Field Configuration dialog box:  
1. Select the field to be modified.  
2. Click on the Modify button.  
The following dialog box appears.  

![Modify Field dialog box](image)

*Figure 7–3: Modify Field dialog box*
3. In the Name field, the name of the field can be modified.
4. In the Type field, the field type can be modified.
5. In the Value field, the fields default value can be modified.

If the name, type and default values of a field are modified, all information that has been inputted for the various components associated to this field will be lost.

6. Click on the OK button to return to the Field Configuration dialog box or click on the Cancel to ignore the changes.

The modified field is now in the list.

7. Repeat steps 1 through 6 for each field to be modified.

### 7.1.3. Deleting a User-Defined Field

It is important to note that only user-defined fields can be deleted. To delete a user-defined field from the Field Configuration dialog box:

1. Select the user-defined field (coloured).
2. Click on the Delete button.

The following warning message appears:

![Field Delete Warning Message Box](image)

*Figure 7–4: Field Delete Warning Message Box*

If a user-defined field is deleted and was associated to one or more components, all information in the fields will be lost as well as the association to the components.

3. Click on Yes to proceed with the deletion or No to cancel the delete.

The field is removed from the list.
7.1.4. Associating User-Defined Fields to a Component

To associate a user-defined (previously created) to a single component:

1. Double-click on the component to which the field must be associated.

   The Component Properties dialog box appears.

2. Click on the Catalog Information branch.

   The Part Information and Accessory List are visible.

3. Click on the Add Field button in the Part Information zone.

   The Add Field button will only be available if the report workshop was installed.

The Field Selection dialog box appears on the screen:

4. Click on the OK button and the fields will be updated in the Component Properties dialog box or click on Cancel to cancel all changes.

![Field Selection dialog box](image)

Figure 7–5: Field Selection dialog box

The list on the left contains all of the standard and user-defined fields that can be associated to components. The list on the right contains all the fields that are associated to the component.
User-defined fields will appear in a different colour than standard fields.

The following buttons can be used in this dialog box:

<table>
<thead>
<tr>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>A</td>
<td>Moves the selected field from the left list to the right list. The field is associated with the component.</td>
</tr>
<tr>
<td>B</td>
<td>Moves the selected field from the right list to the left list. The field is no longer associated with the component.</td>
</tr>
<tr>
<td>C</td>
<td>Moves the selected field one position up in the right list.</td>
</tr>
<tr>
<td>D</td>
<td>Moves the selected field one position down in the right list.</td>
</tr>
<tr>
<td>E</td>
<td>Buttons that allow the creation, modification, or deletion of user-defined fields.</td>
</tr>
</tbody>
</table>

### 7.2. Inserting Fields

To insert fields on a diagram:

1. Select Insert → Field.

   The mouse pointer takes the following shape $\leftrightarrow$.

2. With the mouse’s left button, define a region for the field.

   The Component Properties dialog box opens.

3. Click on the Current Project branch in the Categories zone.

   The list of available fields appears in the Fields Name zone.

4. Click on a field to select it.

   The selected field and its value appear in the Field Value zone.

5. Click on the Apply button.

6. Click on the Close button.

   The field value will appear in the previously defined region.
8. Catalog

The catalog function is used to select components from an OEM pre configured list.

⚠️ You must possess the required license to have access to this module. Choose Help → About to find out more about your license.

8.1. Accessing the Catalog

To access the catalog:

1. Insert a component on the diagram.
2. Double-click on the symbol to open the Component Properties dialog box.
3. Select the Catalog Information branch.
4. Click on the Find Part button in the Part Information section.

The Catalog Browser dialog box appears. If the component is associated to one or more descriptions, the information will appear in a table.

5. Sort the table by clicking on the column headings.
6. Click on the desired component description.
7. Click on the Select button.

The Catalog Browser dialog box will close and the information fields in the Component Properties dialog box will be updated as per the selection.
8.1.1. Adding Accessories

To add accessories to a component using the catalog:

1. Insert a component on the diagram.
   Double-click on the symbol to open the Component Properties dialog box.

2. Select the Catalog Information branch.

3. If the accessories list is hidden, click on the Show Accessories button.

4. Click on the Add Accessory button in the Accessory List section.

5. Click on the Find Part button in the Accessory List section.

The Catalog Browser dialog box appears. If the component is associated to one or more accessories, the part information will appear in a table.

6. Sort the table by clicking on the column headings.

7. Click on the desired component description.

8. Click on the Select button.

9. The Catalog Browser dialog box will close and the information fields in the Component Properties dialog box will be updated as per the selection.
8.2. **Saving the Information**

The catalog information is automatically saved when a drawing, project or personalized library is saved.

8.3. **Managing the Information**

To access the information in the various databases, you must possess MS-Access 2000 or greater.

Catalog information is stored and retrieved with the use of four tables in the Catalog database:

- Cross-reference table (CRT)
- Header table (HDT)
- Catalog information table (CAT)
- Accessories table (ACT)

8.3.1. **Cross-Reference Table (CRT)**

The cross-reference table permits a user to associate a certain catalog ID (ID_Cat) to components found in the main library. This ID will then be used to associate information found in the catalog information table (CAT).

The cross-reference table is composed of five columns:

<table>
<thead>
<tr>
<th>Column</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>IDA</td>
<td>Internal component ID. This column must not be modified.</td>
</tr>
<tr>
<td>IDF</td>
<td>Internal component ID. This column must not be modified.</td>
</tr>
<tr>
<td>IDT</td>
<td>Internal component ID. This column must not be modified.</td>
</tr>
<tr>
<td>ID_Cat</td>
<td>Catalog ID.</td>
</tr>
<tr>
<td>Description</td>
<td>Component description. This column must not be modified.</td>
</tr>
</tbody>
</table>

8.3.1.1. **Associating a Component to a Catalog ID**

To associate a component form the main library to a catalog ID:

1. With the help of the component description and internal component ID, find the correct component, in the CRT table.
2. Input the desired ID_Cat (maximum of 255 alphanumerical characters) in the ID_Cat column on the same row.

### 8.3.2. Headers Table (HDT)

The headers table lists the columns that appear in the catalog information table (CAT).

The headers table is composed of two columns:

<table>
<thead>
<tr>
<th>Column</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ID</td>
<td>Header identificator.</td>
</tr>
<tr>
<td>Headers</td>
<td>Header (column title)</td>
</tr>
</tbody>
</table>

To add a column to the CAT table, the column header must appear in this table. All of the column headers (except for ID_Cat) must appear in this table in the same order as they will appear in the CAT table. (For more information, see Adding a Column).

### 8.3.3. Catalog Information Table (CAT)

The catalog information table contains all of the information associated to a certain ID_Cat that will be displayed when the Catalog Browser dialog box is opened.

The catalog information table is composed of the following eight columns:

<table>
<thead>
<tr>
<th>Column</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ID_Cat</td>
<td>Catalog identifier</td>
</tr>
<tr>
<td>Part Number</td>
<td>Part Number</td>
</tr>
<tr>
<td>Manufacturer</td>
<td>Manufacturer</td>
</tr>
<tr>
<td>Catalog Description</td>
<td>Catalog Description</td>
</tr>
<tr>
<td>Inventory Number</td>
<td>Inventory Number</td>
</tr>
<tr>
<td>Unit Price</td>
<td>Unit Price</td>
</tr>
<tr>
<td>Discount</td>
<td>Discount</td>
</tr>
<tr>
<td>Type</td>
<td>Type</td>
</tr>
</tbody>
</table>

The eight basic columns represent the eight basic component properties. There is no limit to the number of columns that can be added to this table.
8.3.3.1. Adding a Column

For the information contained in a new column in the CAT table to appear in the Catalog Browser dialog box:

1. Add a column in the CAT table in the last position. Refer to MS-Access help for more details on adding columns in a table.
2. Rename the new column header using the same name as the corresponding field in the Catalog Information branch of the Component Properties dialog box.
3. Add the name of the header on a new row of the HDT table.

A new number will automatically be attributed to the new header.

8.3.4. Accessories Table (ACT)

The accessories table contains all of the information on accessories that can be added to a component.

The accessories table is made up of five columns:

<table>
<thead>
<tr>
<th>Column</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ID_Cat</td>
<td>Catalog ID</td>
</tr>
<tr>
<td>Part Number</td>
<td>Part Number</td>
</tr>
<tr>
<td>Quantity</td>
<td>Quantity</td>
</tr>
<tr>
<td>Description</td>
<td>Description</td>
</tr>
<tr>
<td>Unit price</td>
<td>Unit price</td>
</tr>
</tbody>
</table>

The ID_Cat to be used is the same as for the component that the accessory will be associated with. No columns can be added to this table.

8.3.4.1. Associating an Accessory to Multiple IDs

To associate more than one ID_Cat to an accessory:

1. Copy the entire accessory row.
2. Paste the row.
3. Rename the ID_Cat of the new row to the desired value.
8.4. Custom Components

To associate an ID_Cat to a custom component:

1. Insert a component on the diagram.
   Double-click on the symbol to open the Component Properties dialog box.
2. Select the Catalog Information branch.
3. Insert the desired ID_Cat in the ID_Cat field.
4. Insert the component in the personalized library.

For more information on personalized libraries see Library Explorer.

In the case of a grouped component, check the Assembly option in the Catalog Information branch of the grouped component prior to assigning an ID_Cat.
9. Managing Reports

9.1. Creating a Report

To create a new report, first you have to create a project with diagrams. Let us assume that you have already completed this operation and let us emphasize the process of report creation.

The following example shows how to create a general report.

To create a report:

1. Select File → New → Report

The Report Template dialog box opens.

2. Select the type of report to produce, such as “Generic”.

The Report Configuration dialog box opens and allows you to configure the new report.

Once the report characteristics have been defined:

3. Click on the OK button to generate the report.

![Figure 9–1: Report Templates dialog box](image)
Figure 9–2: Report Configuration dialog box, Filter Configuration tab

Figure 9–3: Report Configuration dialog box, Field Selection tab
Figure 9–4: Report Configuration dialog box, Global Settings tab

The following figure represents a report. It is an information spreadsheet where columns correspond to the property associated with a component and rows correspond to the value of these properties.
If the report characteristics are to be modified, use the Edit → Options command when the report is active.

At this point, the report will appear in the project’s tree in the Project explorer.

The Report Configuration dialog box is split into three tabs: Filter Configuration, Field Selection, and Global Settings. For a Variables List type report, only the Field Selection tab is available.

The following table describes the different zones and buttons found in the Filter Configuration tab of the Report Configuration dialog box:
### Zone Description

<table>
<thead>
<tr>
<th>Zone</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Diagram list</td>
<td>• Lists all of the diagrams existing in the project. The report can be generated for a specific diagram or for a certain number of specific diagrams.</td>
</tr>
<tr>
<td></td>
<td>• By default, all of the diagrams in the current project are selected and will be in the report. Diagrams that are not to be included in the report must be deselected.</td>
</tr>
<tr>
<td></td>
<td>• Clicking on it will deselect a diagram; the name will not be highlighted.</td>
</tr>
<tr>
<td>Workshop list</td>
<td>• Displays the list of workshops used in the selected diagrams.</td>
</tr>
<tr>
<td></td>
<td>• By default, all of the workshops are selected and will be in the report. Workshops that are not to be included in the report must be deselected.</td>
</tr>
<tr>
<td></td>
<td>• For example, if a diagram contains components from the hydraulic and electric workshops, by selecting only the hydraulics workshop, only components that come from that specific workshop, and are present in the diagram will appear in the list.</td>
</tr>
<tr>
<td>Components list</td>
<td>• Every component from the selected diagram and workshops will appear in this list. It is selected by default.</td>
</tr>
<tr>
<td></td>
<td>• Deselect components that are not to be in the report. This will remove certain components from the report.</td>
</tr>
<tr>
<td></td>
<td>• Selected components are highlighted.</td>
</tr>
<tr>
<td></td>
<td>• This button can change depending on the position of the mouse pointer. It is used to select all of the diagrams, workshops, or components.</td>
</tr>
<tr>
<td></td>
<td>• All of the diagrams, workshops, and components are selected by default.</td>
</tr>
<tr>
<td></td>
<td>• This button can change depending on the position of the mouse pointer. It is used to deselect all of the diagrams, workshops, or components.</td>
</tr>
<tr>
<td></td>
<td>• All of the diagrams, workshops, and components are selected by default.</td>
</tr>
<tr>
<td>Accessories included in the report</td>
<td>• This option will include all component accessories in the report.</td>
</tr>
</tbody>
</table>

---

**9-5**
The following table describes the selection lists that make up the Field Selection tab of the Report Configuration dialog box:

<table>
<thead>
<tr>
<th>Lists</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Fields</td>
<td>Displays the catalog information fields or the fields that have already been configured for the report. Fields are composed of simulation parameters, catalog information, and used-defined. The Available Fields can be added to a report. The Selected Fields are the ones that will appear in the report.</td>
</tr>
</tbody>
</table>

The following table describes the fields that make up the Global Settings tab of the Report Configuration dialog box:

<table>
<thead>
<tr>
<th>Fields</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Display the Grand Total</td>
<td>Displays the Global Discount (%), Taxes (%), and Miscellaneous Fees.</td>
</tr>
<tr>
<td>Global Discount (%)</td>
<td>Discount applied on the total of the unit price field.</td>
</tr>
<tr>
<td>Taxes (%)</td>
<td>Taxes applied on the amount after discount.</td>
</tr>
<tr>
<td>Miscellaneous Fees</td>
<td>Fees applied to the amount after taxes.</td>
</tr>
</tbody>
</table>

> When a new report is created, it will be named in a generic fashion i.e. Report followed by a sequential number. The name of the report can be modified by either using the contextual menu of the report in the Project Explorer or from the Document Properties command of the Edit menu.

The software comes equipped with standard pre-configured report templates.

### 9.2. Modifying a Report

The modification of the report fields must be done via the Edit menu. The Edit menu is composed of the Insert, Delete, and Options commands.

The Insert and Delete commands are made up of the Row and Column commands.

#### 9.2.1. Insert

To insert a column in a report:

1. Select Edit → Insert → Column.

The Report Edit Warning message box appears.
2. Click on the OK button.
The New Field Title dialog box asking for the new field title appears.
3. Input the name of the new column.
4. Click on the OK button.
The procedure is the same to insert a row except that a new name will not be requested.

### 9.2.2. Delete

To delete a row from a report:
1. Select Edit → Delete → Row.
The Report Edit Warning message appears on the screen.
2. Click on the OK button.
The row on which is positioned the pointer is deleted. The same procedure is used to delete a column.

### 9.3. Organizing Report Data

Report data can be sorted or grouped. The sorting/grouping of report data is performed from the Data menu.

#### 9.3.1. Sorting Data

To sort data in a report:
1. Select Data → Sort.
The Sort dialog box appears on screen.
2. Select the column in which the data must be sorted by.
3. Select ascending or descending sorting order.
Repeat for a second or third sorting criteria.
4. Click on the OK button.
Report data is sorted as per the selections.
9.3.2. Grouping Data

To group report data:

1. Select Data → Group.

   The Group dialog box appears on the screen.

2. Select grouping or no grouping for the report.

3. Click on the OK button.

Report data is grouped as per the selection.
10. I/O Interface Card

The I/O interface card was designed to complement the other simulation workshops of Automation Studio.

This section presents all of the information needed to use the card. This information includes the realisation and simulation of a project as well as a practical example of an application.

For physical installation and configuration of the card, please refer to the provided documentation.

The I/O interface card is part of the Interface family in the Automation Studio library. Installation of this card is not included with the basic installation, it must be done independently. The procedure is described in the following section.

The I/O interface card allows interactions between the simulation workshops of Automation Studio and PLCs (programmable logic controller). With the included RBB relay interface, users can also control the circuits simulated on screen and connect simulation circuits on field devices such as solenoid valves, push buttons, etc. or on the sensors of an existing circuit or training panel.

![Image of PLC and I/O Interface Card]

*Figure 10–1: Interaction between the software and a PLC*

The information is presented in the same order as the tasks to be executed. This chapter is organized to follow as closely as possible the sequence of tasks to simulate a circuit interacting with a peripheral device.
However, this document does not cover the theoretical notions concerning peripheral devices. This guide was written assuming that users are already familiar with communication notions as well as Input/Output interfaces with peripheral devices.

This chapter presents the following information:

- Using the I/O interface card with Automation Studio.
- An example of a circuit interacting with the interface card.

## 10.1. Using the I/O Interface Card

This section presents the information needed to use the interface card with the Automation Studio software.

The information is presented in the following order:

- Inserting the I/O interface card in a diagram;
- Defining I/O interface card component properties.

### 10.1.1. Inserting the I/O Interface Card into a Diagram

In a diagram, inserting the symbol representing the I/O interface card is done like any other component from Automation Studio.

To insert an I/O interface card in a diagram:

1. Select Window → Display → Library Explorer.

The Library Explorer window appears.

2. In the library, click on the Interface root then on the BIC Interface branch.

The interface card components appear in the library component window.

3. Select the component that corresponds to the type of card installed in your computer (ISA/PCI or USB).
4. Insert the selected component into the diagram.

5. Double-click on the component to open the Component Properties dialog box.

The Component Properties dialog box opens.

10.1.2. Configuration Properties

To access the configuration properties of the card, click on the Configuration branch in the properties tree.

Adjust the configuration to fit the card installed on the system. (See the provided documentation).

10.1.3. Display Properties

To access the display properties of the I/O interface card click on the Displayed Information branch of the properties tree.

Select the desired display options and keep the default card name.
10.1.4. Variable Assignment Properties

To access the variables assignment properties of the I/O interface card, click on the Variables Assignment branch of the properties tree.

10.2. Practical Example Using the I/O Interface Card

This section presents a practical example of an I/O card connected to a PLC.

The following tasks are to be performed:

- Building the circuit;
- Defining the circuit sequence;
- Defining the ladder diagram;
- Assigning input and output variables to the electrical circuit components;
- Simulating the circuit and communicating with the PLC via the I/O interface card.

10.2.1. Building the Circuit

The following figure presents the PLC controlled electropneumatic circuit to be simulated. The PLC outputs are connected to the I/O interface card inputs and the card outputs to the PLC inputs.
The circuit is composed of two cylinders (A1 and A2), each controlled by a double solenoid 5/2 valve. Proximity sensors are used to detect the in and out positions of the cylinders. A pushbutton is used to start the sequence.

The INTER01.PR4 file containing this exercise can be found in the EXERCISES folder of the application.

### 10.2.2. Defining the Sequence

This is the functioning sequence of the circuit. It is first described then represented with the help of an SFC. This sequence must be programmed into the PLC. Further, along, we will translate this sequence into a ladder diagram to program the PLC.

**Step 1:**

On step 1, by activating the A1- and A2- solenoids, both cylinders rods are retracted.
Step 2:
As soon as the START button is clicked and both cylinders retracted (A1_0 and A2_0 proximity sensors) the sequence is started. At this moment, transition 1 is cleared and step 2 is activated. Once step 2 is activated, solenoid A1+ is energized, therefore extracting the A1 cylinder rod. Once the rod is fully extended, the A1_1 proximity sensor is activated.

Step 3:
Transition 2 is then cleared and step 3 is activated. With the activation of step 3, the A2+ solenoid is energized; this will extract the rod of cylinder A2. Once the rod is fully extended, the A2_1 proximity sensor is then activated.

Step 4:
Transition 3 is then cleared and step 4 is activated. The A2- solenoid is energized and the A2 cylinder rod is retracted. Once the rod is completely retracted, proximity sensor A2_0 is then activated.

Step 5:
Transition 4 is cleared and step 5 activated. Solenoid A1- is activated and the A1 cylinder rod is retracted. Once the rod is completely retracted, proximity sensor A1_0 is the activated. This will clear transition 5 and return to the first step. The automatism is now ready for another cycle.

The following figure presents the sequence in SFC format.
10.2.3. Sequence Ladder Logic Diagram

The following figure presents the circuit sequence ladder logic diagram. The following tables present the corresponding tag names for the inputs and outputs of the interface card and of the corresponding components.
You can reproduce this diagram with the use of your PLC software. Once the PLC is programmed, the sequence can be tested by starting the simulation.

When applying the program for a specific PLC, make sure that the correct I/O addresses are used. In the following example, the addresses must correspond to the wiring between the I/O interface card and the PLC.
For example, a command schematic for an Allen-Bradley PLC could have the following corresponding addresses:

<table>
<thead>
<tr>
<th>PLC Tag name</th>
<th>Allen-Bradley Address</th>
<th>Connection to the I/O interface card</th>
<th>PLC Tag name</th>
<th>Allen-Bradley Address</th>
<th>Connection to the I/O interface card</th>
</tr>
</thead>
<tbody>
<tr>
<td>DEPART</td>
<td>I:1/0</td>
<td>OUT0</td>
<td>Y2</td>
<td>B3 :0/1</td>
<td>N/A</td>
</tr>
<tr>
<td>A1_0</td>
<td>I:1/1</td>
<td>OUT1</td>
<td>Y3</td>
<td>B3 :0/2</td>
<td>N/A</td>
</tr>
<tr>
<td>A1_1</td>
<td>I:1/2</td>
<td>OUT2</td>
<td>Y4</td>
<td>B3 :0/3</td>
<td>N/A</td>
</tr>
<tr>
<td>A2_0</td>
<td>I:1/3</td>
<td>OUT3</td>
<td>Y5</td>
<td>B3 :0/4</td>
<td>N/A</td>
</tr>
<tr>
<td>A2_1</td>
<td>I:1/4</td>
<td>OUT4</td>
<td>X1</td>
<td>B3 :1/0</td>
<td>N/A</td>
</tr>
<tr>
<td>A1+</td>
<td>O:2/0</td>
<td>IN0</td>
<td>X2</td>
<td>B3 :1/1</td>
<td>N/A</td>
</tr>
<tr>
<td>A1-</td>
<td>O:2/1</td>
<td>IN1</td>
<td>X3</td>
<td>B3 :1/2</td>
<td>N/A</td>
</tr>
<tr>
<td>A2+</td>
<td>O:2/2</td>
<td>IN2</td>
<td>X4</td>
<td>B3 :1/3</td>
<td>N/A</td>
</tr>
<tr>
<td>A2-</td>
<td>O:2/3</td>
<td>IN3</td>
<td>X5</td>
<td>B3 :1/4</td>
<td>N/A</td>
</tr>
<tr>
<td>Y1</td>
<td>B3 :0/0</td>
<td>N/A</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

A command schematic for a Modicon PLC could have the following corresponding addresses:

<table>
<thead>
<tr>
<th>PLC Tag name</th>
<th>Modicon Address</th>
<th>Connection to the I/O interface card</th>
<th>PLC Tag name</th>
<th>Modicon Address</th>
<th>Connection to the I/O interface card</th>
</tr>
</thead>
<tbody>
<tr>
<td>DEPART</td>
<td>10001</td>
<td>OUT0</td>
<td>Y2</td>
<td>01101</td>
<td>N/A</td>
</tr>
<tr>
<td>A1_0</td>
<td>10002</td>
<td>OUT1</td>
<td>Y3</td>
<td>01102</td>
<td>N/A</td>
</tr>
<tr>
<td>A1_1</td>
<td>10003</td>
<td>OUT2</td>
<td>Y4</td>
<td>01103</td>
<td>N/A</td>
</tr>
<tr>
<td>A2_0</td>
<td>10004</td>
<td>OUT3</td>
<td>Y5</td>
<td>01104</td>
<td>N/A</td>
</tr>
<tr>
<td>A2_1</td>
<td>10005</td>
<td>OUT4</td>
<td>X1</td>
<td>01200</td>
<td>N/A</td>
</tr>
<tr>
<td>A1+</td>
<td>00001</td>
<td>IN0</td>
<td>X2</td>
<td>01201</td>
<td>N/A</td>
</tr>
<tr>
<td>A1-</td>
<td>00002</td>
<td>IN1</td>
<td>X3</td>
<td>01202</td>
<td>N/A</td>
</tr>
<tr>
<td>A2+</td>
<td>00003</td>
<td>IN2</td>
<td>X4</td>
<td>01203</td>
<td>N/A</td>
</tr>
<tr>
<td>A2-</td>
<td>00004</td>
<td>IN3</td>
<td>X5</td>
<td>01204</td>
<td>N/A</td>
</tr>
<tr>
<td>Y1</td>
<td>01100</td>
<td>N/A</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
10.2.4. Assigning I/O Variables to the Electrical Circuit Components

In order to establish a connection between the circuit components and the interface card, the I/O variables must now be assigned. To access the variables assignment properties of the component, select the Variables Assignment branch of the properties tree in the Component Properties dialog box.

The following is the correspondence table between the electrical components of the circuit and the I/O interface card.

<table>
<thead>
<tr>
<th>Read-only output tag names for circuit components</th>
<th>Component type</th>
<th>Tag name</th>
</tr>
</thead>
<tbody>
<tr>
<td>LOIC1.OUT0</td>
<td>NO Pushbutton</td>
<td>1-1PBN01.DEPART</td>
</tr>
<tr>
<td>LOIC1.OUT1</td>
<td>Proximity sensor</td>
<td>1-1S1.A1_0</td>
</tr>
<tr>
<td>LOIC1.OUT2</td>
<td>Proximity sensor</td>
<td>1-1S2.A1_1</td>
</tr>
<tr>
<td>LOIC1.OUT3</td>
<td>Proximity sensor</td>
<td>1-1S3.A2_0</td>
</tr>
<tr>
<td>LOIC1.OUT4</td>
<td>Proximity sensor</td>
<td>1-1S4.A2_1</td>
</tr>
</tbody>
</table>

The default input tag names must be modified according to the following table, but prior to linking them to the valve solenoids:

<table>
<thead>
<tr>
<th>Read-only components linked to I/O card inputs</th>
<th>Input</th>
<th>Tag name</th>
</tr>
</thead>
<tbody>
<tr>
<td>Solenoid SOL1 of valve 1-1V1</td>
<td>LOIC1.IN0</td>
<td>A1+</td>
</tr>
<tr>
<td>Solenoid SOL2 of valve 1-1V1</td>
<td>LOIC1.IN1</td>
<td>A1-</td>
</tr>
<tr>
<td>Solenoid SOL1 of valve 1-1V2</td>
<td>LOIC1.IN2</td>
<td>A2+</td>
</tr>
<tr>
<td>Solenoid SOL2 of valve 1-1V2</td>
<td>LOIC1.IN3</td>
<td>A2-</td>
</tr>
</tbody>
</table>

10.3. Simulating the Circuit Connected to a PLC

The use of the I/O interface card allows you to establish a link between a simulation of components and real devices. You can validate a circuit by connecting it to real components or you can validate a PLC program by connecting it to a simulation circuit in Automation Studio.

When a circuit is simulated, the output signals emitted by the simulated circuit are transmitted via the I/O interface card to the external components to which it is associated. All of the components that have tag names mapped to an output in the I/O Interface Card dialog box transmit a signal to a peripheral device when they are activated. In the same manner, all the
components that have a tag name mapped to an input in the I/O Interface Card dialog box are activated by a signal emitted from the peripheral device.

To avoid the transmission of erroneous signals to a peripheral device, it is recommended that you first test the circuit in Automation Studio without establishing the communication with the I/O interface card. To remove the connection between the card and the software deselect the Activation option in the properties dialog box.

To simulate the circuit:

1. Select the Activation option in the properties dialog box.
2. Start the simulation.
   The Simulation mode is active.
3. Activate the pushbutton that allows the start up of the circuit simulation by clicking on it. (1-1PBNO1.START).
   In the I/O interface card component symbol in the diagram, the input and output cells change colour as they transmit or receive signals. The input cells only change colour if they are associated with a peripheral device.
4. Exit the Simulation mode and return to the Edit mode.
   The simulation stops.
   The Status bar indicates that the application is now in the Edit mode.
11. Software Configuration

To configure the Automation Studio software:

1. Select Tools → Options.
The Configuration dialog box appears.

2. Select the branch you wish to modify.

3. Make the necessary changes to the software configuration by navigating through the various options.

4. Click on the Apply button.
The software will apply the changes.

5. Click on the Close button.
The software configuration window closes.

Figure 11–1: Options dialog box
This is the description of the various zones of this dialog box:

<table>
<thead>
<tr>
<th>Zone</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Branch window</td>
<td>Displays all of the branches granting access to the configuration options for each available module of the software.</td>
</tr>
<tr>
<td>Properties</td>
<td>Describes all of the options of a branch as well as information type and default value.</td>
</tr>
<tr>
<td>Configuration</td>
<td>Describes the visible options for a certain branch.</td>
</tr>
</tbody>
</table>

Several options, such as the language selection, require for the user to relaunch the application.

11.1. List of Options

11.1.1. Application

<table>
<thead>
<tr>
<th>Option</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>User Name</td>
<td>Specify user name</td>
</tr>
<tr>
<td>Company</td>
<td>Specify Company</td>
</tr>
<tr>
<td>Undo Depth</td>
<td>Specify the number of possible “undo”s</td>
</tr>
<tr>
<td>Language</td>
<td>Specify software language</td>
</tr>
<tr>
<td>Component Units</td>
<td>Specify unit system for components</td>
</tr>
<tr>
<td>Rulers Units</td>
<td>Specify units for drawing rulers</td>
</tr>
<tr>
<td>New Project on Start</td>
<td>Select to have a new project automatically on start-up</td>
</tr>
<tr>
<td>Always Create Backup Copy</td>
<td>Select to have a backup copy created by default</td>
</tr>
<tr>
<td>Always Prompt Summary Info at the First Save</td>
<td>Select to have summary information appear when saving a file for the first time</td>
</tr>
<tr>
<td>Recently Used File List</td>
<td>Specify the number of files to appear in the recent files list</td>
</tr>
<tr>
<td>Default Simulation Mode</td>
<td>Specify the default simulation mode</td>
</tr>
<tr>
<td>Project Templates Folder</td>
<td>Specify the folder for project templates</td>
</tr>
<tr>
<td>Option</td>
<td>Function</td>
</tr>
<tr>
<td>--------------------------</td>
<td>----------------------------------------------------</td>
</tr>
<tr>
<td>Diagram Templates Folder</td>
<td>Specify the folder for diagram templates</td>
</tr>
<tr>
<td>SFC Templates Folder</td>
<td>Specify the folder for SFC templates</td>
</tr>
<tr>
<td>Report Templates Folder</td>
<td>Specify the folder for Report templates</td>
</tr>
<tr>
<td>Autosave Library on Close</td>
<td>Select to have library save on close</td>
</tr>
</tbody>
</table>

### 11.1.2. Diagram Editor

<table>
<thead>
<tr>
<th>Option</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default Diagram Width</td>
<td>Specify the width of the drawing page</td>
</tr>
<tr>
<td>Default Diagram Height</td>
<td>Specify the height of the drawing page</td>
</tr>
<tr>
<td>Default Diagram Orientation</td>
<td>Specify the orientation of the drawing page</td>
</tr>
<tr>
<td>Default Diagram Margin</td>
<td>Specify the margins of the drawing page</td>
</tr>
<tr>
<td>Default Diagram Scale</td>
<td>Specify the scale of the drawing page</td>
</tr>
<tr>
<td>Display Grid by Default</td>
<td>Select to view grid by default</td>
</tr>
<tr>
<td>Display Rulers by Default</td>
<td>Select to view rulers by default</td>
</tr>
<tr>
<td>Display Connectors by Default</td>
<td>Select to view connectors by default</td>
</tr>
<tr>
<td>Display Mechanical Contacts by Default</td>
<td>Select to view mechanical contacts by default</td>
</tr>
<tr>
<td>Display Connection Numbers by Default</td>
<td>Select to view connection numbers by default</td>
</tr>
<tr>
<td>Initial Zoom Page</td>
<td>Select to apply an initial zoom to the page</td>
</tr>
</tbody>
</table>

### 11.1.3. Kernel

<table>
<thead>
<tr>
<th>Option</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Component Fault Colour</td>
<td>Specify the colour of a faulty component</td>
</tr>
<tr>
<td>Free Connections Colour</td>
<td>Specify the colour of free connections</td>
</tr>
</tbody>
</table>
### 11.1.4. CAD Workshop

<table>
<thead>
<tr>
<th>Option</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default Line Colour</td>
<td>Specify the default line colour</td>
</tr>
<tr>
<td>Default Line Style</td>
<td>Specify the default line style</td>
</tr>
<tr>
<td>Default Line Width</td>
<td>Specify the default line width</td>
</tr>
<tr>
<td>Default Fill Pattern</td>
<td>Specify the default fill pattern</td>
</tr>
<tr>
<td>Default Background Colour</td>
<td>Specify the default background colour</td>
</tr>
<tr>
<td>Default Foreground Colour</td>
<td>Specify the default foreground colour</td>
</tr>
<tr>
<td>Default Line Begin</td>
<td>Specify the default line begin style</td>
</tr>
<tr>
<td>Default Line Begin Size</td>
<td>Specify the default line begin size</td>
</tr>
<tr>
<td>Default Line End</td>
<td>Specify the default line end style</td>
</tr>
<tr>
<td>Default Line End Size</td>
<td>Specify the default line end size</td>
</tr>
<tr>
<td>Default Font</td>
<td>Specify the default font</td>
</tr>
<tr>
<td>Default Font Height</td>
<td>Specify the default font height</td>
</tr>
<tr>
<td>Default Font Bold</td>
<td>Select for default font style bold</td>
</tr>
<tr>
<td>Default Font Italic</td>
<td>Select for default font style italic</td>
</tr>
<tr>
<td>Default Font Underline</td>
<td>Select for default font style underline</td>
</tr>
<tr>
<td>Default Font Strikeout</td>
<td>Select for default font style strikeout</td>
</tr>
<tr>
<td>Automatic Polygon Closure</td>
<td>Select for polygon automatic closure</td>
</tr>
<tr>
<td>Word Wrap</td>
<td>Allows for automatic line returns in a text box</td>
</tr>
</tbody>
</table>
### 11.1.5. SFC Module

<table>
<thead>
<tr>
<th>Option</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default Diagram Width</td>
<td>Specify the width of the drawing page</td>
</tr>
<tr>
<td>Default Diagram Height</td>
<td>Specify the height of the drawing page</td>
</tr>
<tr>
<td>Default Diagram Orientation</td>
<td>Specify the orientation of the drawing page</td>
</tr>
<tr>
<td>Default Diagram Margin</td>
<td>Specify the margins of the drawing page</td>
</tr>
<tr>
<td>Default Diagram Scale</td>
<td>Specify the scale of the drawing page</td>
</tr>
<tr>
<td>Display Grid by Default</td>
<td>Select to view grid by default</td>
</tr>
<tr>
<td>Display Rulers by Default</td>
<td>Select to view rulers by default</td>
</tr>
<tr>
<td>Display Connectors by Default</td>
<td>Select to view connectors by default</td>
</tr>
<tr>
<td>Initial Zoom Page</td>
<td>Select to apply an initial zoom to the page</td>
</tr>
<tr>
<td>Fit Vergences Automatically</td>
<td>Select to have vergences fit automatically</td>
</tr>
<tr>
<td>Automatic Jump-to Label on Rising Link</td>
<td>Select to have automatic jump-to labels applied to rising links</td>
</tr>
<tr>
<td>Automatic Open Properties dialog box</td>
<td>Select to have the properties dialog box open automatically on component insertion</td>
</tr>
<tr>
<td>Statements (action, transition), Level 2</td>
<td>Select to be able to specify level 2 statements</td>
</tr>
<tr>
<td>Comments, Level 1</td>
<td>Select to be able to specify level 1 comments</td>
</tr>
<tr>
<td>Boolean Animation</td>
<td>Select to have Boolean type simulation</td>
</tr>
<tr>
<td>Numerical Animation</td>
<td>Select to have numerical type simulation</td>
</tr>
<tr>
<td>Active Step Scrolling</td>
<td>Select to have active step scrolling</td>
</tr>
<tr>
<td>Apply Colours to Syntax Elements</td>
<td>Select to have syntax elements coloured during edition</td>
</tr>
<tr>
<td>Operators Colour</td>
<td>Specify the colour of operators</td>
</tr>
<tr>
<td>Numbers Colour</td>
<td>Specify the colour of numbers</td>
</tr>
<tr>
<td>Tag Names Colour</td>
<td>Specify the colour of tag names</td>
</tr>
<tr>
<td>Option</td>
<td>Function</td>
</tr>
<tr>
<td>--------------------------------</td>
<td>-----------------------------------------------</td>
</tr>
<tr>
<td>Undefined Tag Names Colour</td>
<td>Specify the colour of undefined tag names</td>
</tr>
<tr>
<td>Active Component Colour</td>
<td>Specify the colour of active components</td>
</tr>
</tbody>
</table>

### 11.1.6. Simulation Module

<table>
<thead>
<tr>
<th>Option</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Slow Speed Factor</td>
<td>Specify a slow speed factor</td>
</tr>
<tr>
<td>Beta hydraulic</td>
<td>Specify hydraulic beta factor</td>
</tr>
<tr>
<td>Atmospheric Pressure (kN/ATM)</td>
<td>Specify atmospheric (ambient) pressure</td>
</tr>
<tr>
<td>G</td>
<td>Specify gravity (acceleration)</td>
</tr>
</tbody>
</table>

### 11.1.7. Plotter Module

<table>
<thead>
<tr>
<th>Option</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Black Background Colour</td>
<td>Specify the colour for the plotting area of the evolution curves.</td>
</tr>
<tr>
<td>Grid Colour</td>
<td>Specify the colour of the grid for the plotting area of the evolution curves.</td>
</tr>
<tr>
<td>Scale Colour</td>
<td>Specify the colour of the time scale below the plotting area of the evolution curves.</td>
</tr>
<tr>
<td>Graphe1 Colour</td>
<td>Specify the colour of the first variable in the list.</td>
</tr>
<tr>
<td>Graphe2 Colour</td>
<td>Specify the colour of the second variable in the list.</td>
</tr>
<tr>
<td>Graphe3 Colour</td>
<td>Specify the colour of the third variable in the list.</td>
</tr>
<tr>
<td>Graphe4 Colour</td>
<td>Specify the colour of the fourth variable in the list.</td>
</tr>
<tr>
<td>Graphe5 Colour</td>
<td>Specify the colour of the fifth variable in the list.</td>
</tr>
<tr>
<td>Display Time in Seconds</td>
<td>Specify the default number of seconds the curve will be displayed in the plotting area.</td>
</tr>
<tr>
<td>Maximum Number of Values for a Plot</td>
<td>Maximum number of points memorized during the plotting of a curve.</td>
</tr>
<tr>
<td><strong>Option</strong></td>
<td><strong>Function</strong></td>
</tr>
<tr>
<td>-------------------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Line Thickness</td>
<td>Specify the thickness of the line used to draw the curve in the plotting area as well as in the scale.</td>
</tr>
</tbody>
</table>

### 11.1.8. Hydraulic Workshop

<table>
<thead>
<tr>
<th><strong>Option</strong></th>
<th><strong>Function</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>Link Width in Simulation</td>
<td>Specify the width of the pressure lines during simulation</td>
</tr>
<tr>
<td>Flow Arrow Width</td>
<td>Specify the width of the flow arrowhead during simulation</td>
</tr>
<tr>
<td>Flow Arrow Height</td>
<td>Specify the height of the flow arrowhead during simulation</td>
</tr>
<tr>
<td>Minimum Pressure</td>
<td>Specify the circuit minimum pressure</td>
</tr>
<tr>
<td>Low Pressure Limit</td>
<td>Specify the pressure at which lines are considered low pressure</td>
</tr>
<tr>
<td>High Pressure Limit</td>
<td>Specify the pressure at which lines are considered high pressure</td>
</tr>
<tr>
<td>Maximum Pressure</td>
<td>Specify the circuit maximum pressure during simulation</td>
</tr>
<tr>
<td>High Pressure Line</td>
<td>Specify the high pressure line colour during simulation</td>
</tr>
<tr>
<td>Low Pressure Line</td>
<td>Specify the low pressure line colour during simulation</td>
</tr>
<tr>
<td>Vacuum Pressure Line</td>
<td>Specify the vacuum pressure line colour during simulation</td>
</tr>
<tr>
<td>Undetermined Pressure Line</td>
<td>Specify the undetermined pressure line colour during simulation</td>
</tr>
<tr>
<td>High Pilot Line</td>
<td>Specify the high pressure pilot line colour during simulation</td>
</tr>
<tr>
<td>Low Pilot Line</td>
<td>Specify the low pressure pilot line colour during simulation</td>
</tr>
<tr>
<td>Vacuum Pilot Line</td>
<td>Specify the vacuum pilot line colour during simulation</td>
</tr>
<tr>
<td>Undetermined Pilot Line</td>
<td>Specify the undetermined pilot line colour during simulation</td>
</tr>
<tr>
<td>Drain Line Colour</td>
<td>Specify the drain line colour during simulation</td>
</tr>
<tr>
<td>Show Flow Direction</td>
<td>Select to have flow arrows appear during simulation</td>
</tr>
</tbody>
</table>
A. Shortcuts

You can simplify or speed up certain operations by using certain key combinations or key/mouse combinations. This appendix describes all of the key combinations that are possible in Automation Studio.

Appendix A is divided into three sections:
- Keyboard shortcuts
- Navigation keys
- Mouse shortcuts.

A.1 Keyboard Shortcuts

Shortcut keys allow you to quickly execute the most frequently used commands. They are generally associated with commands that are common to all the utilities.

A.1.1 File Menu

<table>
<thead>
<tr>
<th>Shortcut</th>
<th>Command</th>
</tr>
</thead>
<tbody>
<tr>
<td>CTRL+N</td>
<td>New</td>
</tr>
<tr>
<td>CTRL+O</td>
<td>Open</td>
</tr>
<tr>
<td>CTRL+S</td>
<td>Save</td>
</tr>
<tr>
<td>CTRL+P</td>
<td>Print</td>
</tr>
<tr>
<td>ALT+F4</td>
<td>Exit</td>
</tr>
</tbody>
</table>

A.1.2 Edit Menu

<table>
<thead>
<tr>
<th>Shortcut</th>
<th>Command</th>
</tr>
</thead>
<tbody>
<tr>
<td>CTRL+Z</td>
<td>Undo</td>
</tr>
<tr>
<td>CTRL+Y</td>
<td>Redo</td>
</tr>
<tr>
<td>ALT+ENTER</td>
<td>Properties</td>
</tr>
<tr>
<td>CTRL+X</td>
<td>Cut</td>
</tr>
<tr>
<td>CTRL+C</td>
<td>Copy</td>
</tr>
</tbody>
</table>
### Shortcut Command

<table>
<thead>
<tr>
<th>Shortcut</th>
<th>Command</th>
</tr>
</thead>
<tbody>
<tr>
<td>CTRL+V</td>
<td>Paste</td>
</tr>
<tr>
<td>CTRL+D</td>
<td>Duplicate</td>
</tr>
<tr>
<td>DEL</td>
<td>Delete</td>
</tr>
<tr>
<td>CTRL+A</td>
<td>Select all</td>
</tr>
<tr>
<td>F2</td>
<td>Allows the editing of text component</td>
</tr>
</tbody>
</table>

#### A.1.3 View Menu

<table>
<thead>
<tr>
<th>Shortcut</th>
<th>Command</th>
</tr>
</thead>
<tbody>
<tr>
<td>CTRL++</td>
<td>Zoom +</td>
</tr>
<tr>
<td>CTRL+-</td>
<td>Zoom -</td>
</tr>
<tr>
<td>CTRL+Q</td>
<td>Component snap</td>
</tr>
</tbody>
</table>

#### A.1.4 Layout Menu

<table>
<thead>
<tr>
<th>Shortcut</th>
<th>Command</th>
</tr>
</thead>
<tbody>
<tr>
<td>CTRL+H</td>
<td>Rotate right</td>
</tr>
<tr>
<td>CTRL+F</td>
<td>Vertical flip</td>
</tr>
<tr>
<td>CTRL+T</td>
<td>Horizontal flip</td>
</tr>
<tr>
<td>CTRL+page up</td>
<td>Bring to front</td>
</tr>
<tr>
<td>CTRL+page down</td>
<td>Send to back</td>
</tr>
<tr>
<td>SHIFT+page up</td>
<td>Bring forward</td>
</tr>
<tr>
<td>SHIFT+page down</td>
<td>Send backward</td>
</tr>
<tr>
<td>CTRL+G</td>
<td>Group</td>
</tr>
<tr>
<td>CTRL+U</td>
<td>Ungroup</td>
</tr>
<tr>
<td>CTRL+J</td>
<td>Convert link to jump</td>
</tr>
<tr>
<td>CTRL+L</td>
<td>Direct link</td>
</tr>
</tbody>
</table>
A.1.5 Window → Display Menu

<table>
<thead>
<tr>
<th>Shortcut</th>
<th>Command</th>
</tr>
</thead>
<tbody>
<tr>
<td>F6</td>
<td>Opens Toolbar selection box</td>
</tr>
<tr>
<td>F7</td>
<td>Opens Message window</td>
</tr>
<tr>
<td>F8</td>
<td>Opens Project Explorer</td>
</tr>
<tr>
<td>F9</td>
<td>Opens Library Explorer</td>
</tr>
<tr>
<td>F10</td>
<td>Opens Plotter</td>
</tr>
<tr>
<td>F11</td>
<td>Opens Status bar</td>
</tr>
<tr>
<td>F12</td>
<td>Opens Variable Manager</td>
</tr>
</tbody>
</table>

A.1.6 Help Menu

<table>
<thead>
<tr>
<th>Shortcut</th>
<th>Command</th>
</tr>
</thead>
<tbody>
<tr>
<td>F1</td>
<td>Contextual help</td>
</tr>
</tbody>
</table>

A.2 Navigation Keys

Navigation keys allow you to move depending on the type and position of the selection.

A.2.1 Navigation Keys Within the Explorers

<table>
<thead>
<tr>
<th>Shortcut</th>
<th>Movement</th>
</tr>
</thead>
<tbody>
<tr>
<td>↑</td>
<td>Go one line up</td>
</tr>
<tr>
<td>↓</td>
<td>Go one line down</td>
</tr>
<tr>
<td>Page Up</td>
<td>Go to the top of the tree</td>
</tr>
<tr>
<td>Home</td>
<td>Go to the bottom of the tree</td>
</tr>
</tbody>
</table>

A.2.2 Navigation Keys in the Drawing Editor on a Selected Component

<table>
<thead>
<tr>
<th>Shortcut</th>
<th>Movement</th>
</tr>
</thead>
<tbody>
<tr>
<td>→</td>
<td>Moves the component one grid step to the right.</td>
</tr>
<tr>
<td>←</td>
<td>Moves the component one grid step to the left.</td>
</tr>
</tbody>
</table>
Shortcut | Movement
--- | ---
↑ | Moves the component one grid step up.
↓ | Moves the component one grid step down.
CTRL+→ | Moves the screen view to the right.
CTRL+← | Moves the screen view to the left.
CTRL+↑ | Moves the screen view up.
CTRL+↓ | Moves the screen view down.
HOME | Moves the screen view to the upper right corner.
END | Moves the screen view to the lower left corner.
CTRL+HOME | Moves the screen view upper left corner.
CTRL+END | Moves the screen view lower right corner.

A.3 Mouse Shortcuts

A.3.1 Project Explorer

<table>
<thead>
<tr>
<th>Action</th>
<th>On</th>
<th>Effect</th>
</tr>
</thead>
<tbody>
<tr>
<td>Left click</td>
<td>a diagram</td>
<td>selects the diagram</td>
</tr>
<tr>
<td>Double left click</td>
<td>a diagram</td>
<td>opens a diagram window</td>
</tr>
</tbody>
</table>

A.3.2 Drawing Editor

<table>
<thead>
<tr>
<th>Action</th>
<th>On</th>
<th>Effect</th>
</tr>
</thead>
<tbody>
<tr>
<td>Left click</td>
<td>a component in the workspace</td>
<td>selects the component.</td>
</tr>
<tr>
<td>Double left click</td>
<td>a component in the workspace</td>
<td>opens the component properties window.</td>
</tr>
<tr>
<td>CTRL + left click</td>
<td>a selected component</td>
<td>duplicates the component.</td>
</tr>
<tr>
<td>CTRL + left click</td>
<td>a rotation handle</td>
<td>applies an orthogonal rotation to the component.</td>
</tr>
<tr>
<td>CTRL + left click</td>
<td>a resizing handle</td>
<td>applies a disproportional resizing to the component.</td>
</tr>
<tr>
<td>CTRL + left click</td>
<td>a rectangle</td>
<td>draws a perfect square.</td>
</tr>
</tbody>
</table>
### Shortcuts

<table>
<thead>
<tr>
<th>Action</th>
<th>On</th>
<th>Effect</th>
</tr>
</thead>
<tbody>
<tr>
<td>CTRL + left click</td>
<td>a ellipse</td>
<td>draws a perfect circle.</td>
</tr>
<tr>
<td>CTRL + left click</td>
<td>an arc</td>
<td>draws a perfect arc of circle.</td>
</tr>
<tr>
<td>SHIFT+ left click</td>
<td>a non-selected component or in the workspace</td>
<td>adds the component to the selection.</td>
</tr>
<tr>
<td>SHIFT + left click</td>
<td>a selected component</td>
<td>removes the component from the selection.</td>
</tr>
<tr>
<td>SHIFT+left click</td>
<td>a component in order to move it</td>
<td>moves the component and severs the links.</td>
</tr>
<tr>
<td>Right click</td>
<td>a component</td>
<td>show the component contextual menu.</td>
</tr>
<tr>
<td>Right click</td>
<td>workspace</td>
<td>show the diagram contextual menu.</td>
</tr>
<tr>
<td>CTRL+scroll wheel</td>
<td>workspace</td>
<td>zooms the page in and out.</td>
</tr>
<tr>
<td>SHIFT+scroll wheel</td>
<td>workspace</td>
<td>moves the page horizontally.</td>
</tr>
<tr>
<td>Scroll wheel</td>
<td>workspace</td>
<td>moves the page vertically.</td>
</tr>
</tbody>
</table>
B. Glossary

Active Workshop
Installed workshop whose components are displayed in the Diagram Editor library.

Alphanumeric
Consisting of both letters and numbers and often other symbols such as punctuation marks and mathematical symbols. The main characters are the 26 letters and 10 numbers.

Assembly
A group considered as a single component in the reports. To view this feature, check the Assembly checkbox in the group properties dialog box.

Automatism
A device, system, or equipment that allows an apparatus to execute specific operations without the intervention of an operator.

Component
The basic elements used for creating diagrams. Each component represents a behaviour or a function that is functioning during simulation. Components are part of the library and are provided by the workshops.

Connection
A connection binds two components and/or links them together. Connections are the same colour as the element if they are connected, different if not connected. Two connections from non-compatible technologies cannot be connected together. For example, a pneumatic line cannot be connected to a SFC component and vice-versa.

Connection Number
A number designated for each point where components are connected.
Connector

Element represented by a red circle when it is not linked. It allows the connection of two components. A connector becomes a connection as soon as it is connected to another element.

Contact Point

Connection linking a emitting component to a receiving component that allows one to influence the behaviour of the other. A lozenge represents these contacts points. Contrary to connections, the colour of the lozenge is not affected by the connection status.

Diagram

A drawing that graphically represents a circuit or a model using elements and components selected from the Automation Studio workshop libraries. Note that only SFC components can be placed in a SFC diagram.

Display Tools

Designates the design accessories in the Diagram Editor: grid, rulers, connections and connection numbers. You can specify how they are displayed from the View menu.

Document Manager

Displays the contents of one of the project editor's windows. The document manager lists all of the documents that make up the project.

Edit Mode

A mode of operation in Automation Studio during which project diagrams can be created and modified. There is another mode of operation, the Simulation mode.

Graphic Object

An element of the Library that cannot be simulated. Graphic objects are inserted into diagrams strictly as non-functional elements. There are four types: rectangles, ellipses, lines, and texts.

Grid

A network of horizontal and vertical dotted lines which covers the workspace in the Diagram Editor and on which the elements of a diagram are aligned.
**Group**

Two or more components forming a single entity.

**Library Explorer**

A window containing the basic elements used for designing circuits or simulation models.

**Link**

A link connects components. During simulation, it is used to transfer information from one component to the other.

**Link Shape**

Path of a link between two points.

**Mechanical Contacts**

Mechanical contacts connect a sensor and a receiver making it possible for a component to modify the behaviour of another component. They are represented by a rhombus that appears at the point of contact. Contrary to connectors, the colour of the rhombuses is not influenced by the state of the connection.

**Menu Bar**

A horizontal bar located above the application title bar. The menu bar displays the various menus and commands that are available for the active window.

**PLC**

Logogram of Programmable Logic Controller.

**Project**

A group of documents forming a cohesive whole. A Project is managed by the Project Manager.

**Project Explorer**

The tool used to create, modify and manage "project" files. The project explorer includes the document manager that manages all the documents in the project.
**Project Label**

A brief description of the project appearing in the project summary.

**Properties**

Characteristics or parameters of a component. You can change or view the properties by opening the component Properties dialog box.

**Rulers**

Rulers are displayed at the edges of the window and indicate the unit of measurement being used for the diagram. They serve as references for diagram size and the relative position of elements.

**SFC**

Sequential Function Chart (SFC). A graphic representation using basic SFC components used to represent an automatism.

**Simulation Cycle**

One step in the calculation that determines the state of each component.

**Simulation Mode**

the mode of operation in Automation Studio in which a project or a diagram is simulated. Unlike the Edit mode, the Simulation mode, when active, does not allow any change to the project.

**Sort Key**

The criteria used to classify items of the Diagram list in alphanumeric order. The sort keys are specified in the Sort box of the Tools menu in the Project Manager. The alphanumeric order is as follows: 0,1,2...9,A,B,C....Y,Z.

**Status Bar**

Horizontal bar located at the bottom of all of the utility windows. It contains various types of information such as error messages, zoom factor, mouse pointer coordinates, etc.
**System Menu**

A standard Windows menu that is available in all of the windows of Automation Studio. A box in the upper left corner of each window accesses it. For more information, see the Windows User Guide.

**Title Bar**

the horizontal bar located at the top of a window that contains the title of the window.

**Toolbar**

A bar located under the menu bar that contains buttons for the most frequently used commands.

**User Interface**

The environment made up of windows, dialog boxes, graphic objects, etc. with which the user communicates with the software.

**Utility**

A general designation for the different types of windows in Automation Studio. The Core System contains two utilities: the Project Manager and the Diagram Editor.

**Worksheet**

The entire surface available in Automation Studio for generating diagrams.

**Workshop**

A module that plugs into the Core System. Each workshop contains elements, diagrams and functions that relate to its own technological specialty and to the type of diagram it can generate.

**Workspace**

The part of the window that displays the information you are working on such as graphs, tables, and the item list of the application).
C. Index

Catalog .................................................. 8-1
Accessing ............................................. 8-1
Accessories ........................................... 8-2
Catalog ID ............................................. 8-3
Custom Components ............................... 8-6
Information ........................................... 8-3
Tables .................................................... 8-3
Cross-Reference ....................................... 8-3
Table
Accessories ........................................... 8-5
Catalog .................................................. 8-4
Columns ............................................... 8-5
Headers ................................................... 8-4
Communication ........................................ 10-11
Component
Associating User-Defined Fields ........... 7-5
Deleting User-Defined Fields ............... 7-4
Inserting ............................................... 10-2
Modifying User-Defined Fields ............. 7-3
User-Defined Fields ............................... 7-2
Components
Standard Fields ...................................... 11-1
Connection
Display ................................................... 5-44
Moving .................................................... 5-10
Verify ..................................................... 5-57
Verify Connections ................................. 5-15
Contextual Menu ...................................... 3-39
Open ....................................................... 3-39

Conventions
Key Combinations and Key Sequences ........ 1-4
Core System
Documentation Structure ....................... 1-1
Creation
Diagram .................................................. 5-1
Document ................................................. 4-1
Project ..................................................... 4-1
Diagram
Creation .................................................. 5-1
Page Setup .............................................. 5-1
Diagram Editor ......................................... 3-1
Static Elements ....................................... 3-2
Title Bar .................................................... 3-2
Display
Connection Ports Name ......................... 5-44
Displayed Information
Format ..................................................... 5-9
Modify ...................................................... 5-9
Document
Creation ................................................. 4-1
Management ............................................. 4-1
Summary Info ............................................ 5-4
Element
Copy ....................................................... 5-42
Deleting .................................................... 5-41
Duplicating ............................................. 5-40
Orientation .............................................. 5-41
Index

Duplicate ...................................... 3-7
Paste .......................................... 3-6
Redo .......................................... 3-6
Select All ...................................... 3-7
Undo .......................................... 3-6

File ................................................... 3-2
Close Project................................. 3-3
Exit ............................................... 3-5
New .............................................. 3-3
New Project .................................. 3-3
Open Project.................................. 3-3
Print .............................................. 3-5
Print Preview ................................ 3-5
Project Properties ......................... 3-5
Save as Template ......................... 3-4
Save Project.................................. 3-4
Save Project as.............................. 3-5
Send to.......................................... 3-5

Help................................................ 3-20
About .......................................... 3-22
Context Help............................... 3-20
Help Content............................... 3-21
Online Support ......................... 3-21
  Automation Studio on the Web.............. 3-22
  Client Support Page ...................... 3-21
  Discussion Forum ...................... 3-21
  Frequently Asked Questions .............. 3-21
  Suggestions .................................. 3-22
Software Registration ................. 3-21
Insert .............................................. 3-10

  Arc.............................................. 3-10
  Bill of Materials.......................... 3-11
  BOM........................................... 3-11
  Ellipse........................................ 3-10
  Field............................................ 3-11
  Line............................................. 3-10
  Link ............................................. 3-11

  Picture .........................................3-11
  Polygon ........................................ 3-11
  Rectangle................................. 3-10
  Text .............................................3-11

Layout..........................................3-11
  Break Link .................................. 3-14
  Bring Forward............................. 3-13
  Bring to Front............................. 3-13
  Convert Link to Jump.................... 3-14
  Direct Link ..................................3-13
  Group ...........................................3-13
  Horizontal Flip .......................... 3-12
  Join Links................................. 3-14
  Rotate 180° ............................... 3-12
  Rotate Left ..................................3-12
  Rotate Right ..................................3-12
  Send Backward............................ 3-13
  Send to Back ............................... 3-13
  Ungroup.......................................3-13
  Vertical Flip ................................3-12

Simulation......................................3-14
  Document ....................................3-15
  Normal.........................................3-15
  Pause ...........................................3-15
  Project ........................................3-15
  Select Items to Simulate .............. 3-15
  Selection.................................... 3-15
  Slow Motion..................................3-15
  Step by Step ..................................3-15
  Stop .............................................3-15

Tools..............................................3-16
  Export.........................................3-16
  Field Configuration ..................... 3-16
  Options ........................................3-16
  Update Components ..................... 3-16
  Verify Connections ...................... 3-16

View .................................................3-7
  Component Snap .......................... 3-9
  Connection Ports ....................... 3-9
Connection Ports Names .................. 3-9
Contact Points ............................ 3-9
Grid .......................................... 3-9
Grid Properties ............................ 3-10
Page Zoom ................................ 3-9
Panning ..................................... 3-9
Previous Zoom ............................ 3-8
Rulers ....................................... 3-9
Window Zoom ................................ 3-8
Zoom - ....................................... 3-8
Zoom + ....................................... 3-8
Zoom All Components .................... 3-9
Window ....................................... 3-18
Cascade ..................................... 3-20
Close All Windows ....................... 3-19
Display ...................................... 3-19
  Library Explorer ........................ 3-19
  Messages ................................ 3-19
  Plotter .................................. 3-20
  Project Explorer ....................... 3-19
  Status Bar ................................ 3-20
  Toolbars ................................ 3-19
  Variables Explorer .................... 3-20
Horizontal Tile ............................ 3-20
New Window ................................ 3-19
Open Project or Diagram Window ...... 3-20
Vertical Tile ................................ 3-20
Menu Bar
  Diagram Editor ........................... 3-2
Messages
  Window ...................................... 3-29
PLC ......................................... 10-4, 10-10
  Programmable Logic Controller ... 10-10
Plot
  Deleting .................................. 6-5
Plotter ...................................... 3-27, 6-1
Accessing ................................. 6-1
Apply ........................................ 3-29
Cancel ....................................... 3-29
Color ........................................ 3-29
Colour ....................................... 6-3
Component ................................ 3-29
Current Unit ............................... 3-29
Curve ....................................... 6-3
Data .......................................... 6-3
Delete ........................................ 3-29
Export ....................................... 3-29
Graph ........................................ 3-28
Help .......................................... 3-29
Interval-Time ............................... 3-29
Modifying ................................... 6-4
Name ......................................... 3-29
Properties .................................. 3-29
Properties List ............................. 3-28
Scale ......................................... 3-28
  Maximum ................................ 3-29
  Minimum ................................ 3-29
Using ........................................ 6-2
Variable ..................................... 3-29
Variables .................................... 6-5
Pop-up Menu ................................. 3-39
Open .......................................... 3-39
Specific Commands ....................... 3-39
  Animation ................................ 3-40
  Drain ...................................... 3-39
  Icons ....................................... 3-40
  Pilot ....................................... 3-39
  Pressure ................................... 3-39
  Rename .................................... 3-40
  Setting .................................... 3-40
Index

Programmable Logic Controller ........ 10-1
PLC .............................................. 10-10

Project
  Closing ........................................ 4-4
  Creation ....................................... 4-1
  General ....................................... 4-10
  Management ................................... 4-1
  New ............................................... 4-1
  Open ........................................... 4-3
  Save ........................................... 4-10

Project Explorer
  Tree Window .................................. 3-33

Reports .............................................. 9-6
  Create ........................................ 9-1

Ruler
  Display ....................................... 5-45
  Selecting an Element ........................ 5-38

Selection
  Framing ....................................... 5-39
  Selection Select All .......................... 5-40

SFC .............................................. 10-4

Shortcut
  Keyboard ...................................... 1

Signals .............................................. 10-10

Simulation
  Circuit ........................................ 10-10
  Diagram ....................................... 5-55
  Launch ........................................ 5-54, 5-55
  Mode Description ............................. 5-53
  Pause ........................................... 5-57
  Speed Selection .............................. 5-55
  Stop ........................................... 5-57

Status Bar ....................................... 3-27

Toolbar
  Format ........................................ 3-27
  Color .......................................... 3-27
  Thickness ..................................... 3-27
  Library Explorer ............................. 3-32
  Create Category .............................. 3-32
  Create Library ............................... 3-32
  Delete Category .............................. 3-32
  Lock/Unlock Library .......................... 3-32
  Open Library ................................. 3-32
  Save Library .................................. 3-32

Library Explorer Toolbar
  Library Explorer ................................ 3-31

Toolbars
  Edit ............................................ 3-23
  Copy .......................................... 3-23
  Cut ........................................... 3-23
  Paste .......................................... 3-23
  Properties .................................... 3-23
  Redo .......................................... 3-23
  Undo .......................................... 3-23

Insert .......................................... 3-25
  Arc ............................................ 3-25
  Ellipse ....................................... 3-25
  Field .......................................... 3-26
  Image .......................................... 3-26
  Line ........................................... 3-26
  Links .......................................... 3-25
  Polygon ........................................ 3-25
  Rectangle ..................................... 3-25
  Selection ...................................... 3-25
  Text ........................................... 3-26

Layout ............................................ 3-26
  Break Link .................................... 3-26
  Bring to Front ................................ 3-26
  Convert Link to Jumps ...................... 3-26
  Direct Link ................................... 3-26

C-5
Free Rotation ........................................... 3-26
Group .................................................. 3-26
Horizontal Flip ..................................... 3-26
Join Links ............................................ 3-26
Rotate Left 90° ..................................... 3-26
Rotate Right 90° .................................. 3-26
Send to Back ....................................... 3-26
Ungroup ............................................. 3-26
Vertical Flip ......................................... 3-26
Project ................................................. 3-22
Library Explorer .................................. 3-23
New Diagram ....................................... 3-23
New Project ......................................... 3-22
New Report ......................................... 3-23
New SFC ............................................... 3-23
Open .................................................. 3-22
Print .................................................. 3-23
Project Explorer .................................. 3-23
Save .................................................... 3-23
Variable Explorer .................................. 3-23
Simulation ........................................... 3-24
Document Simulation ......................... 3-24
Normal ............................................... 3-24
Pause .................................................. 3-24
Plotter ................................................. 3-24
Project Simulation .............................. 3-24
Select Items to Simulate ..................... 3-24
Selection Simulation ............................ 3-24
Slow Motion ....................................... 3-24
Step by Step ......................................... 3-24
Stop ..................................................... 3-24
View ..................................................... 3-24
Panning .............................................. 3-25
Zoom
  + .................................................... 3-25
  All Components ................................. 3-25
  Page ................................................. 3-25
  Page Width ...................................... 3-25
  Panning .......................................... 3-25

Percentage .......................................... 3-25
Window .............................................. 3-25

Using the I/O Interface Card .............. 10-2
Variable
  Manager .......................................... 3-34
  Variable Supervision ......................... 3-38
  Variables ........................................... 6-5
  Verify Connections ......................... 5-57
Window Layout .................................. 3-18
Window Messages ............................... 3-29
Windows
  Organizing ........................................ 3-17